Project

General

Profile

Emulator Issues #7637

Audio Issues on both backends in Super Mario Sunshine

Added by kill8r over 5 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
DSPHLE
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?
Super Mario Sunshine

Game ID?
GMSE01

What's the problem? Describe what went wrong in few words.
Semi-Predictable Audio Dropout during gameplay, Video audio remains functional

What did you expect to happen instead?
Correct audio playback

What steps will reproduce the problem?
[Don't assume we have ever played the game and know any level names. Be as
specific as possible.]
1.Play the game normally until you get to the second level, right after mario gets accused.
2.Either during the level opening or the level itself the audio will drop out.
3.

Dolphin 3.5 and 3.5-367 are old versions of Dolphin that have
known issues and bugs, so don't report issues about them and test the
latest Dolphin version first.
Which versions of Dolphin did you test on?
4.0-3089

Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?
4.0-2494

What are your PC specifications? (including, but not limited to: Operating
System, CPU and GPU)
Celeron G1610 2.65 GHz Duel Core
Raedon R7 250x 2GB
4 GB DDR3

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)
[Upload big files to a hosting service and post links here!]
Game refuses to boot at all if low level audio emulation is used, though that might be due to the fact that i dont have the wii dsp files.

[Do not attach files to this issue. Upload them to another site and
link here. Use imgur.com for images and pastie.org for logs. Monitor the
email address that was used to create this issue.]


Related issues

Is duplicate of Emulator - Emulator Issues #7143: DualCore timing issuesNew

Has duplicate Emulator - Emulator Issues #7655: Audio issues in HLEDuplicate

History

#1 Updated by pauldacheez over 5 years ago

  • Status changed from New to Accepted
  • Regression set to Yes
  • Category changed from dsphle to dsplle

Can you narrow down that range of builds and find which exact build broke it? (It's quicker than you'd think, just check the build exactly between the last working build you know of and the first broken build you know of (e.g. (2494 + 3089) / 2 = ~2792) and see if it works or not, then repeat until you find the exact build that causes the bug. This is referred to as "bisecting".)

LLE should work even without a real DSP dump – Dolphin currently includes a reverse-engineered DSP ROM that works just as well in most cases (exceptions being odd differences in volume for certain sounds in certain games; this game has no known issues of any kind, though). If it's not working at all, that's probably the fault of whatever change you're bisecting for, not the DSP ROM's fault.

#2 Updated by kill8r over 5 years ago

I tried 3087 and the issue still happened, though i managed to capture the logs for both audio backends.
http://pastie.org/9534402 OpenAL
http://pastie.org/9534409 XAudio
I also noticed some Unknown Execptions and the framerate dropping when the audio cuts out. Could have something to do with how the backends deal with emulator sync

#3 Updated by kill8r over 5 years ago

i have gone as far back as 2358 and the issue still happens. is there anyway to reinstall XAudio and OpenAL? I even tried DSound and it still appeared!

#4 Updated by pauldacheez over 5 years ago

  • Status changed from Accepted to Questionable
  • Regression changed from Yes to No

You said 4.0-2494 was working earlier - is that not true?

I'll page JMC47 to see if he can reproduce any of this.

#5 Updated by kill8r over 5 years ago

It was, but i deleated relocated Dolphin's folder in the Documents folder so i could make sure it wasnt because of one of my settings and now all the backends do it.

#6 Updated by kill8r over 5 years ago

replaced the Dolphin folder and the issue stands, going to try and reinstall OpenAL

#7 Updated by gamedevistator over 5 years ago

I only have problem with OpenAL with this game where the audio comes in late for example in the the beginning with the Nintendo logo and then the goo M logo where it goes to the video on the plane and after that some times the audio will cut then come back, but Xaudio has no issues for me with this game.

#8 Updated by pauldacheez over 5 years ago

gamedevistator: That's fully expected with OpenAL on any game, it's a shit backend right now.

JMC47 said this is just an issue with the game not running at full speed on dual-core, so either don't use dual-core or upgrade your hardware. (Or try comex's gpu-determinism branch and put "GPUDeterminismMode = fake_completion" in your Dolphin.ini.)

#9 Updated by kill8r over 5 years ago

So it's an issue with the audio desyncing due to the game not running fast enough?

#10 Updated by JMC4789 over 5 years ago

It's an issue with how Dolphin cheats to get more performance in dualcore. If it doesn't happen in Singlecore, it can enter a long lineup of games that have problems when a computer is in that threshold where one thread slows down and the other doesn't.

#11 Updated by kill8r over 5 years ago

Is there any way to regain audio after the error as my computer only lags on certian areas and then jumps back to normal.

#12 Updated by pauldacheez over 5 years ago

issue 7655 has been merged into this issue.

#13 Updated by JMC4789 over 5 years ago

  • Status changed from Questionable to Duplicate

This really sounds to me like an issue that dualcore determinism would solve at the cost of some performance. Because that feature is on the horizon, I'm going to mark this as a duplicate.

Also available in: Atom PDF