Project

General

Profile

Emulator Issues #7646

Mario Kart Arcade GP Version 2 - Crash on boot

Added by wifiandcoffee over 5 years ago. Updated almost 3 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

[READ THIS: https://forums.dolphin-emu.org/showthread.php?pid=276132 <<<
Your answers are there!]
[Leave the questions as they are and answer them in the next line]
[Remove lines written inside brackets [], but nothing else]

Game Name?
Mario Kart Arcade GP 2 (Game is listed in Dolphin as Sample Game Name with No Banner

Game ID?
Not sure

What's the problem? Describe what went wrong in few words.
The ROM will display a blank black screen when emulated for about 10 seconds then two error messages appear "Unknown DVD command fb000000 - fatal error" and "Unknown DVD command 41000000 - fatal error" How can I get this game to run?

What did you expect to happen instead?
All settings as far as I am aware are correct. I expected the ROM to boot maybe with some lag or glitching but be playable.
What steps will reproduce the problem?
[Don't assume we have ever played the game and know any level names. Be as
specific as possible.]
1. Selecting the ROM from the Dolphin Main Screen and attempting to play it
2. Nothing - once the emulation starts, the issues begin
3.

Dolphin 3.5 and 3.5-367 are old versions of Dolphin that have
known issues and bugs, so don't report issues about them and test the
latest Dolphin version first.
Which versions of Dolphin did you test on?
4.0.2

Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?

What are your PC specifications? (including, but not limited to: Operating
System, CPU and GPU)
PC: Windows 8 x86
CPU: Intel (R) Celeron CPU 1000M @ 1.80GHz 1800Mhz 2 cores 2 logical processors
GPU: Intel Graphics Adapter HD
Is there any other relevant information? (e.g. logs, screenshots,
configuration files)
LOG: 19:59:909 Src\ConfigManager.cpp:140 N[BOOT]: Saving settings to C:/Users/USER/Documents/Dolphin Emulator/Config/Dolphin.ini
20:00:412 Src\Boot\Boot.cpp:199 N[BOOT]: Booting H:\Dolphin Emulator TriForce\ISO AND GCN/MarioKartGP2.gcm
20:00:635 Src\HLE\HLE_OS.cpp:43 N[OSREPORT]: 812003e8->81300000|
Apploader Initialized.
20:00:635 Src\HLE\HLE_OS.cpp:43 N[OSREPORT]: 81200404->81300000| This Apploader built Apr 16 2004 22:09:36
20:00:683 Src\HLE\HLE_OS.cpp:43 N[OSREPORT]: 81200868->81300000| APPLOADER WARNING >>> Physical memory size is 0x1800000 bytes.
APPLOADER WARNING >>> Console simulated memory size (0x3000000) must be smaller than or equal to the Physical memory size
APPLOADER WARNING >>> Use physical memory size as the console simulated memory size.....


Related issues

Is duplicate of Emulator - Emulator Issues #9761: Add Triforce SupportAccepted

History

#1 Updated by pauldacheez over 5 years ago

  • Status changed from New to Accepted

This game has only worked on the old (3.0-700s-era, I think?) Triforce branch, which was never merged due to code quality issues. The discussion hasn't been brought up in a while - thanks for reminding us it exists. :D

Unrelated: your PC is pretty awful for Dolphin and you're not gonna have a good time with it. (We also don't support x86-32 OSes anymore, and Dolphin's always been much faster on x86-64 OSes.)

#2 Updated by Stevoisiak about 5 years ago

The ID number for the PAL version of Mario Kart GP2 is RELSAB. Coincidentally, this is the same ID as the Sonic Adventure Preview Prototype.

In my testing, the game will run on the Dolphin Triforce build 3.0-698, but only if the user has the following config file in User\Config.

https://dl.dropboxusercontent.com/u/31068935/Hosted%20Files/Dolphin.ini

#3 Updated by mariotaotao18 about 5 years ago

is there a way to run triforce games via newest build? on the old triforce support ver only mario gp and fzero is playable
thanks

#4 Updated by Stevoisiak about 5 years ago

Dolphin has specialized builds made for Triforce games, but the last update was over 9 months ago, so your results may vary.

https://dolphin-emu.org/download/list/Triforce/1/

#5 Updated by mariotaotao18 about 5 years ago

thanks, but this one use a same config path as the original build, is it possible to change the path to a different folder?

#6 Updated by pauldacheez about 5 years ago

Builds that old don't have any option to change the config path on Windows.

#7 Updated by JMC4789 almost 3 years ago

#8 Updated by JMC4789 almost 3 years ago

  • Status changed from Accepted to Duplicate

Also available in: Atom PDF