Project

General

Profile

Emulator Issues #7659

Dolphin for Android, OpenGLES shaders fail to compile on stock Moto X.

Added by ds84182 over 6 years ago. Updated about 5 years ago.

Status:
Won't fix
Priority:
Normal
Assignee:
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name? All games

Game ID? ALGMS1

What's the problem? Describe what went wrong in few words.
Pixel shaders fail to compile.

What did you expect to happen instead?
For shaders to compile.

What steps will reproduce the problem?
1. Get a Moto X (this may affect all Ardeno GPUs)
2. Get the lastest dolphin
3. Turn on OpenGLES

Dolphin 3.5 and 3.5-367 are old versions of Dolphin that have
known issues and bugs, so don't report issues about them and test the
latest Dolphin version first.
Which versions of Dolphin did you test on?
Affects all Dolphin for Android versions.

Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?
None.

What are your PC specifications? (including, but not limited to: Operating
System, CPU and GPU)
Adreno 320

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)
Bad pixel shaders
http://hastebin.com/raw/arucefupol
There are hundreds of them...

History

#1 Updated by ds84182 over 6 years ago

Also, this causes a black screen when you attempt to run games with the OpenGLES renderer. Was really look9ng forward to seeing Kirby Air Ride boot on my phone...

#2 Updated by JMC4789 over 6 years ago

  • Status changed from New to Questionable

Is this fixed in newer drivers?

#3 Updated by ds84182 over 6 years ago

Possibly, but I would have to wait until Android L rolls out for any driver
updates.

#4 Updated by ds84182 about 6 years ago

Whatever, revisiting this, and it turns out that the Adreno drivers cannot bit shift ivecs by scalars or other ivecs. You can only do component by component. It's a simple bug to fix, but it requires MORE DRIVER SPECIFIC FIXES! YAY!

#5 Updated by Sonicadvance1 about 5 years ago

  • Status changed from Questionable to Won't fix

We no longer support any devices that have this issue.

Also available in: Atom PDF