Project

General

Profile

Emulator Issues #7691

GCPad does not detect device input

Added by alexchandel over 5 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
OS X
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?
All, including Super Mario Sunshine

Game ID?
All.

What's the problem? Describe what went wrong in few words.
GCPad no longer detects input from an external controller. In particular, PS3 controllers (as Input/0/PLAYSTATION(R)3 Controller) do not work, neither when connected via USB nor bluetooth.

What did you expect to happen instead?
In the GCPad configuration, button presses and analog stick movements should be displayed. In games, the game should respond to input.

What steps will reproduce the problem?
0. Connect a controller.
1. Verify it works correctly on Dolphin 4.0.
2. Open Dolphin 4.0-3382.
3. Open GCPad.
4. Select the controller from the device list.
4. Attempt to configure the controller.
5. GCPad doesn't detect any input.

Dolphin 3.5 and 3.5-367 are old versions of Dolphin that have
known issues and bugs, so don't report issues about them and test the
latest Dolphin version first.
Which versions of Dolphin did you test on?
Dolphin 4.0-3382

Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?
Dolphin 4.0 works correctly

What are your PC specifications? (including, but not limited to: Operating
System, CPU and GPU)
OS X 10.9.5 x86-64
Intel i7-3520M 2.9GHz dual-core (ivy bridge)
Intel HD Graphics 4000

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)
No.


Related issues

Is duplicate of Emulator - Emulator Issues #7537: As of 4.0-2167, input configs no longer display current input on OS XFixed

History

#1 Updated by JMC4789 over 5 years ago

  • Operating system OS X added

I'll flash the pauldachz signal. We updated SDL, so I'm guessing there's something that needs reconfiguring.

#2 Updated by alexchandel over 5 years ago

@JMC4789 which PR was that? I'll test the previous version.

#3 Updated by alexchandel over 5 years ago

Possible dupe of #7537

#4 Updated by pauldacheez over 5 years ago

  • Status changed from New to Duplicate

I’m voting dupe of issue 7537.

Also available in: Atom PDF