Project

General

Profile

Emulator Issues #7715

Frame dumper skips duplicate frames (Crash Tag Team Racing)

Added by jayork42 almost 6 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

[READ THIS: https://forums.dolphin-emu.org/showthread.php?pid=276132 <<<
Your answers are there!]
[Leave the questions as they are and answer them in the next line]
[Remove lines written inside brackets [], but nothing else]

Game Name?

Crash Tag Team Racing (NTSC)

Game ID?

G9RE7D

What's the problem? Describe what went wrong in few words.

When dumping frames in the platforming areas (main hub area) the recorded video does not play back at a consistant frame rate. This game implements a variable frame rate by duplicating/skipping frames at certain times (particularly during races when the frame rate is dropped to 30fps)/ When the game draws a frame twice to avoid drops in performance, Dolphin's frame dumper ignores this and instead dumps the next frame that is actually rendered. This results in very wild and unwatchable video during the playback of the AVI.

What did you expect to happen instead?

The video should play back at the same speed the game was being run at. This would be the case if the frame dumper included duplicate frames instead of skipping them.

What steps will reproduce the problem?
[Don't assume we have ever played the game and know any level names. Be as
specific as possible.]

  1. Start the game and begin a new game.
  2. Begin the initial training stage and get to the cutscene where Crash arrives at the top of the elevator.
  3. Skip the scene. Walk forward and take the elevator down, then enter the park and start walking in various places.

Dolphin 3.5 and 3.5-367 are old versions of Dolphin that have
known issues and bugs, so don't report issues about them and test the
latest Dolphin version first.
Which versions of Dolphin did you test on?

Dolphin 4.0 official x64

Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?

I believe I have always had this problem with this game.

What are your PC specifications? (including, but not limited to: Operating
System, CPU and GPU)

Windows 7 Professional x64
Intel i5 4570 (Haswell) stock speed
GeForce GT 240
8GB RAM

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)
[Upload big files to a hosting service and post links here!]

I can upload a short sample video if needed.

[Do not attach files to this issue. Upload them to another site and
link here. Use imgur.com for images and pastie.org for logs. Monitor the
email address that was used to create this issue.]


Related issues

Is duplicate of Emulator - Emulator Issues #7505: Avi dumping should dump 50/60 frames per second.Fixed

History

#1 Updated by JMC4789 almost 6 years ago

This is being addressed in a PR right now.

#2 Updated by rachelbryk almost 6 years ago

  • Status changed from New to Duplicate

Also available in: Atom PDF