Project

General

Profile

Emulator Issues #7725

Dolphin crashes if DirectX isn't updated.

Added by sebastiaan.goossens almost 6 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Game ID?

What's the problem? Describe what went wrong in few words.
Just reinstalled Windows 7 x64, opened dolphin and tried to run a game. Dolphin gave a critical error about DX failing to load. Dolphin crashes if I click 'Ok'.

What did you expect to happen instead?
Closing of the game screen and returning to the main menu.

What steps will reproduce the problem?
[Don't assume we have ever played the game and know any level names. Be as
specific as possible.]
1. Reinstall windows (or removing DX, is that even possible?)
2. Open dolphin (4.0-3518)
3. Click on a game to run it.
4. Press the 'Ok' button on the error message.

Dolphin 3.5 and 3.5-367 are old versions of Dolphin that have
known issues and bugs, so don't report issues about them and test the
latest Dolphin version first.
Which versions of Dolphin did you test on?
4.0-3518

Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?
Dolphin 4.0.2 works, because it automatically installs some version of DX in the background. But 4.0-3518 only works after running the DirectX End-User Runtime Web Installer.

What are your PC specifications? (including, but not limited to: Operating
System, CPU and GPU)
Windows 7 x64
Intel Core i7-2630QM
Nvidia Quadro 1000M (latest driver)

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)
See error picture

History

#1 Updated by MayImilae almost 6 years ago

  • Status changed from New to Questionable

And what happens when you update DirectX on your own? Does it start working again?

#2 Updated by MayImilae almost 6 years ago

Pinging neobrain.

#3 Updated by NeoBrainX almost 6 years ago

  • Status changed from Questionable to Invalid

No issue here. Releases are shipped with an installer which ships with the DX runtimes for convenience, while nightly builds don't ship with an installer.

#4 Updated by sebastiaan.goossens almost 6 years ago

@NeoBrain,

Shouldn't the program account for the (highly unlikely) case that the DirectX runtime installer fails? It would seem pretty logical that any program avoids to crash under any circumstances.

#5 Updated by NeoBrainX almost 6 years ago

We are not interested in addressing this very unlikely scenario, however, since the solution itself is not really clear and I don't think we have anyone who would consider it important enough to spend time implementing it to begin with.

Also available in: Atom PDF