Project

General

Profile

Emulator Issues #7754

Escape from Bug Island: no minimap.

Added by whateveranone over 5 years ago. Updated over 2 years ago.

Status:
Fixed
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?
Escape from Bug Island

Game ID?
RN9P4F

What's the problem? Describe what went wrong in few words.
Minimap can't be seen. You can see small parts of it if you go to and edge of the area, so it's more like it's misaligned than not rendered at all.

What did you expect to happen instead?
To see minimap.

What steps will reproduce the problem?
1. Emulator setting are on defaults.
2.Start the game, skip cinematics, either do tutorial or skip it, either way as soon as gameplay starts map that should be in the corner is invisible or you can only see tiny part of it's edge.
3.

Dolphin 3.5 and 3.5-367 are old versions of Dolphin that have
known issues and bugs, so don't report issues about them and test the
latest Dolphin version first.
Which versions of Dolphin did you test on?
4.0-3655, 4.0.2, 4.0, 2.0.

Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?
No.

What are your PC specifications? (including, but not limited to: Operating
System, CPU and GPU)
Win 7 x64 SP1, Core i5-2400, 8GB ram, NVIDIA gtx 580, GeForce 344.11 Drivers

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)

I tried pretty much every option in graphics section, different emulation, setting, even when everything set to be as safe as possible, minimap doesn't work.

History

#1 Updated by JMC4789 over 5 years ago

Screenshot + Fifolog -> https://wiki.dolphin-emu.org/index.php?title=Fifoplayer would be nice.

#2 Updated by whateveranone over 5 years ago

You can't see player character on screenshots for some reason, but map glitch is clearly visible.
http://rghost.ru/58567038.view
http://rghost.ru/58567065.view

Fifilog http://rghost.ru/58567141
You can see character model freaking out on fifo for some reason.

It works fine during the gameplay though.

#3 Updated by JMC4789 over 5 years ago

Try using RealXFB + EFB2RAM + Safe Texture Cache before starting the game. Since it's off the screen and stuff, I don't think it'll help, but it's worth a shot.

#4 Updated by whateveranone over 5 years ago

No, it changed nothing.

#5 Updated by JMC4789 over 5 years ago

  • Status changed from New to Accepted

Try turning on the free camera and messing around with that; follow the instructions in the tooltip. If you can look around and see if floating off to the side, that means we're doing something stupid. Try zooming in/out too.

#6 Updated by whateveranone over 5 years ago

No, only character movement moves the minimap, free camera makes no difference.
http://rghost.ru/58589175.view
It feels like the minimap is being moved around instead of being scrolled but staying in same place.

#7 Updated by JMC4789 about 5 years ago

Can you check in latest master? We fixed offset on UI elements in Super Monkey Ball, so this could possibly be fixed. Thanks!

#8 Updated by whateveranone about 5 years ago

Unfortunately, it appears to be the same in 4.0-5836.

#9 Updated by JMC4789 almost 5 years ago

Maybe it'll work in fast-depth in latest master on D3D or OpenGL? Did more changes to stuff.

#10 Updated by whateveranone almost 5 years ago

I'm very sorry, but it still looks the same.

#12 Updated by whateveranone over 3 years ago

JMC4789 wrote:

Can you try this in PR-4085? https://dl.dolphin-emu.org/prs/pr-4085-dolphin-latest-x64.7z

Don't have the game on me anymore, sorry/

#13 Updated by kolano about 3 years ago

I still need to try twiddling some settings, but I can't even get to the main menu on either the 5.0-424 PR linked above, or the current release. I get a black screen with the "Escape from Bug Island" logo in the lower right corner, but no progress beyond that. Sits at FPS: 0 VPS:60 for extended timeframes.

#14 Updated by whateveranone about 3 years ago

Tried it on 5.0-2245, minimap appears to work as intended on both Direct3D and OpenGL.

#15 Updated by JosJuice about 3 years ago

  • Status changed from Accepted to Fixed

#16 Updated by kolano over 2 years ago

Same hang still seen in 5.0-4607.

Tried OpenGL, DirectX11, and Vulkan backends.

WiiMote related errors are spewed, but no other error logs seen outside of some likely irrelevant errors with LLE DSP/DirectX11.

#17 Updated by kolano over 2 years ago

Since this is "fixed" I'll add a new issue.

Also available in: Atom PDF