Project

General

Profile

Emulator Issues #7791

4.0-3794 broke per-pixel lighting

Added by autofire372 over 5 years ago.

Status:
Fixed
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

[READ THIS: https://forums.dolphin-emu.org/showthread.php?pid=276132 <<<
Your answers are there!]
[Leave the questions as they are and answer them in the next line]
[Remove lines written inside brackets [], but nothing else]

Game Name?
All games

Game ID?
N/A

What's the problem? Describe what went wrong in few words.
Per-pixel lighting is broken. Turning it on causes all kinds of graphical errors.

What did you expect to happen instead?
I expect lighting to be calculated per-pixel and the graphics not to break horribly.

What steps will reproduce the problem?
[Don't assume we have ever played the game and know any level names. Be as
specific as possible.]
1. Enable per-pixel lighting
2. Start any game
3. Cry

Dolphin 3.5 and 3.5-367 are old versions of Dolphin that have
known issues and bugs, so don't report issues about them and test the
latest Dolphin version first.
Which versions of Dolphin did you test on?
4.0-3791, 4.0-3794, 4.0-3810

Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?
Yes; 4.0-3791 and older still work.

What are your PC specifications? (including, but not limited to: Operating
System, CPU and GPU)
Windows 8.1 x64
Intel Core i7-4770k @4.4Ghz
Nvidia GeForce GTX 750 Ti

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)
[Upload big files to a hosting service and post links here!]
Here's what Metroid Prime's menu screen looks like with PPL enabled right now: http://imageshack.com/a/img540/6401/9jPA1Q.png

[Do not attach files to this issue. Upload them to another site and
link here. Use imgur.com for images and pastie.org for logs. Monitor the
email address that was used to create this issue.]

History

#1 Updated by crudelios over 5 years ago

I can confirm this, both OGL and D3D are affected by this (in revs 4.0-3794 and beyond). The issue only happens when Per Pixel Lightning is turned on.

This is how Zelda - WW looks: https://dl.dropboxusercontent.com/u/15465721/dolphin-glitch.jpg

#2 Updated by xwidghet over 5 years ago

Also confirming, here is the F-Zero GX main menu with per pixel lighting on.
http://i.imgur.com/mTwcvUx.png

And this is without it
http://i.imgur.com/e9SQa77.png

#3 Updated by kostamarino over 5 years ago

  • Status changed from New to Accepted

#5 Updated by autofire372 over 5 years ago

comex, that PR does fix this issue, thanks

#6 Updated by kostamarino over 5 years ago

  • Status changed from Accepted to Fixed

Also available in: Atom PDF