Project

General

Profile

Emulator Issues #7811

Memory Check Breakpoints Do Not Show Up

Added by kacmlweimer over 6 years ago. Updated almost 5 years ago.

Status:
New
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?
Mario Kart Double Dash

Game ID?
GM4E01

What's the problem? Describe what went wrong in few words.
Memory Check Breakpoint buttons do not show up.

What did you expect to happen instead?
I expected them to be in the breakpoints tab

What steps will reproduce the problem?
1. build dolphin for debugfast (for me, since I'm on os x, it is "cmake -D FASTLOG=ON .." and then "make")
2. make sure it builds for debugfast by checking the title of the window
3. realize they are not in the breakpoints tab

Dolphin 3.5 and 3.5-367 are old versions of Dolphin that have
known issues and bugs, so don't report issues about them and test the
latest Dolphin version first.
Which versions of Dolphin did you test on?
I have tested from dolphin 3.5, dolphin 4.0, dolphin 4.1, and the latest commit

Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?
See previous.

What are your PC specifications? (including, but not limited to: Operating
System, CPU and GPU)
15" Macbook Pro running Mac OSX Mavericks 10.9.4.
Processor: 2.3 GHz Intel Core i7
Memory: 8gb 1600 MHz DDR3
Graphics: NVIDIA GeForce GT 650M 512 MB

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)
1. I'm on mac os x
2. I do not have easy access to a pc
3. I can place memchecks by clicking next to the memory address, but they do not function properly. the game does not pause when the address is rewritten.


Related issues

Has duplicate Emulator - Emulator Issues #8221: Memory Breakpoints Don't Do AnythingDuplicate

Has duplicate Emulator - Emulator Issues #9250: Dolphin debug fast on linux: memory breakpoints are brokenDuplicate

History

#1 Updated by biolizard89 over 6 years ago

I am having this issue as well in Super Smash Bros Melee 1.0 on Fedora.

#2 Updated by PEmu over 6 years ago

There is no such thing as Dolphin 4.1. Do you mean 4.0.1?

#3 Updated by kacmlweimer over 6 years ago

my apologies, yes

#4 Updated by biolizard89 over 6 years ago

Appears fixed on latest Git.

#5 Updated by kacmlweimer over 6 years ago

Problem is still here for me. No breakpoint buttons or options.

#6 Updated by kacmlweimer over 6 years ago

Now I actually have a weirder problem. the memory address window doesn't update when I pause the game but it does in cheat search

#7 Updated by kacmlweimer over 6 years ago

Memory address window does update again with latest github commit. Also, i noticed something in the output of the cmake command. It says several things are not found. I tried installing a couple of them and it still didn't recognize them. cmake output posted here: http://pastebin.com/yY4tfDec
Hope that helps!

#8 Updated by kacmlweimer over 6 years ago

Hey! I have good news and bad new! Good news is that I found out what is happening. The default size for the dock where the buttons are supposed to be is too small so you just have to resize that. Bad news is that there is a new bug, the breakpoints don't work. :( should I open a new issue for that or keep it on this thread?

#9 Updated by kacmlweimer over 6 years ago

just to add on to what i said earlier, It was a fix from the latest github commit that made it work

#10 Updated by rukai almost 6 years ago

I also have this issue.
I am running Arch Linux.

I tested in 2 versions, 4.0.2 and the latest version on github. I built both with -DFASTLOG='TRUE'.
There is a movable toolbar that sits where the breakpoint buttons go on the breakpoint tab. This 'toolbar' however is completely empty.

Also of note is that the latest version did not display the graphics on the buttons labeled play, pause etc. This did not affect this problem though, as the play/pause buttons were still clickable and functioning.

#11 Updated by kacmlweimer almost 6 years ago

try taking the movable toolbar handle and dragging it all around the perimeter of the window. Eventually it should dock itself on the left side of the window and show the buttons. I believe its a toolbar size issue, but im not sure. The buttons show up for me if I do that but they do not work.

#12 Updated by rukai almost 6 years ago

I have tried moving toolbar handle but could not get it to display the
buttons.

#13 Updated by kacmlweimer almost 6 years ago

And you tried that on the latest github build? This trick only works after dolphin switched to the new GUI backend.

#14 Updated by rukai almost 6 years ago

Yes, you are correct, by moving the toolbar to the side, it pops into existence. I can then also put it back into its original horizontal position.

Also as you said, the breakpoints do not work.
When I try to set an MC, after entering the details, (memory address, write, log & break) and pressing ok, dolphin crashes with Segmentation fault (core dumped)

#15 Updated by kacmlweimer almost 6 years ago

I am having the same issue. It seems that the developers may be ignoring this thread for a little while due to the few people that have dolphin tat use this feature. As far as I know MC's still work on windows, but i have been unable to try it.

#16 Updated by kacmlweimer almost 6 years ago

I have actually opened up another thread for this issue, but nobody is responding.
https://code.google.com/p/dolphin-emu/issues/detail?id=8221&start=100

#17 Updated by jeffrey.pfau almost 6 years ago

I noticed this a few months ago but didn't take much stock in it. I'm not sure I've seen it crash though.

#18 Updated by JosJuice over 5 years ago

#19 Updated by JosJuice over 5 years ago

#20 Updated by JosJuice almost 5 years ago

  • % Done changed from 100 to 0

Also available in: Atom PDF