Project

General

Profile

Emulator Issues #7825

ZTP Speed Hack is missing support for the Korean version of ZTP

Added by redherochildboss over 6 years ago. Updated over 2 years ago.

Status:
Accepted
Priority:
Low
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Feature request
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
Yes
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

[READ THIS: https://forums.dolphin-emu.org/showthread.php?pid=276132 <<<
Your answers are there!]
[Leave the questions as they are and answer them in the next line]
[Remove lines written inside brackets [], but nothing else]

Game Name?
Twilight Princess (Wii)

Game ID?
RZDE01

What's the problem? Describe what went wrong in few words.
I tried to launch the game, it crashed with an error "Invalid write to 0xa0000000 PC 0x80040e2c". Attempting to close Dolphin results in an infinite loop of Invalid write errors, each writing to a different 0xa (0xa0000001, 0xa0000002,etc) but with the PC section staying the same.

What did you expect to happen instead?
Not to crash? Speed hack doesn't necessarily work on the version of the ROM that I have (it normally causes a white screen), but I've never had an actual error message before.

What steps will reproduce the problem?
[Don't assume we have ever played the game and know any level names. Be as
specific as possible.]
1. Enable Hyrule Field Speed Hack.
2. Launch Game.
3. Crash.

Dolphin 3.5 and 3.5-367 are old versions of Dolphin that have
known issues and bugs, so don't report issues about them and test the
latest Dolphin version first.
Which versions of Dolphin did you test on?
4.0-4041

Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?
It never worked, but older versions never showed that error. Not sure what broke it though.

What are your PC specifications? (including, but not limited to: Operating
System, CPU and GPU)
Specs here: http://www.newegg.com/Product/Product.aspx?Item=%20N82E16834152553

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)
Config: http://pastebin.com/UVhynfLT
log: (Absolutely no idea if this is even related)
http://pastebin.com/HeZuBjYZ

History

#1 Updated by skidau over 6 years ago

Would you please try enabling the MMU in the game properties and restarting the game? Let us know if it is any different with the MMU enabled.

#2 Updated by redherochildboss over 6 years ago

I enabled MMU, totally different error message.
The new error is "BackPatch: No register use entry for address 000000001C5B7E58", after which Dolphin crashes and closes.

#3 Updated by JMC4789 over 6 years ago

The code doesn't work for your revision of the game. We need a separate code for every revision of the Wii Twilight Princess.

#4 Updated by redherochildboss over 6 years ago

True, but it didn't work in older versions and I never got that error, just a black screen, so I was hoping having the actual error code could help you.

#5 Updated by chapterhawk over 6 years ago

I have experienced this identical issue. Currently using Version 4.0-4091
For reference I am using the following revision of Twilight Princess
Game ID: RZDE01, Country: USA, Revision: 0, Date: 2006/10/07

Simply adding this to perhaps offer more information.

#6 Updated by JMC4789 over 6 years ago

It seems like Wii games aren't correctly detected by Dolphin's Revision checking, see issue 7855

#7 Updated by redherochildboss over 6 years ago

Sadly, the issue is not fixed by 4.0-4151. "BackPatch: No register use entry for address 00000000" with MMU on, endless Invalid Write errors with MMU off.

#8 Updated by JMC4789 over 6 years ago

Could you get your revision again in a build that has the revision detection fixed?

#9 Updated by redherochildboss over 6 years ago

Still says Revision 0.

#10 Updated by JMC4789 over 6 years ago

Then, I don't know exactly why it is doing that. I believe the Twilight Princess Patch just isn't compatible with all discs then.

#11 Updated by redherochildboss over 6 years ago

Ah, that's a shame.
Don't suppose there's any additional info I can provide to help? Logs, copies of the other BackPatch/Invalid Write error codes, etc?

#12 Updated by joseeltaco over 6 years ago

Can anyone tell me which version the fix does work with?

#13 Updated by JMC4789 over 6 years ago

Revision 2, apparently, now that the revision reading works.

#14 Updated by 2tailedfox over 6 years ago

I seem to have a similar issue. When switching from a supposedly 'rev 0' USA disc (ripped myself), to a pal version (rzdp01) the error goes away and things work well.
The us version, despite my brand new gaming monster rig, will still have terrible slowdown in hyrule field without this setting being able to be checked.

#15 Updated by JMC4789 over 6 years ago

That's because Revision 0 isn't supported by the patch.

#16 Updated by ZephyrSurfer over 6 years ago

What is it with Hyrule field that is so taxing specifically?
What would be the solution to this? Extra info under the option to inform users it will only work with specific revisions or to get the patch to work on all of them?

#17 Updated by pauldacheez over 6 years ago

  • Status changed from New to Accepted

As has been detailed many times, it's not Hyrule Field that's so taxing, it's the minimap rendering and the fact that it requires Dolphin to switch shaders at a ridiculously high rate (which isn't something that happens particularly quickly on modern graphics APIs).

I vote we just get someone to grab all the missing versions of the game and finish the job. Or we just find a better way to implement it so that it automatically finds whichever function it's supposed to be touching instead of having to be spoonfed an address that's different for every version of the game.

#18 Updated by jake about 6 years ago

I've been having the same issue, and searched through the v2 iso for the trouble code mentioned in the original speed hack. Try adding the following patch:

$Hyrule Field Speed Hack for v2
0x80040C38:dword:0x60000000
0x80040C54:dword:0x60000000
0x80040C6C:dword:0x60000000
0x80040C88:dword:0x60000000
0x80040CE0:dword:0x60000000
0x80040CFC:dword:0x60000000
0x80040D14:dword:0x60000000
0x80040D30:dword:0x60000000

#19 Updated by kostamarino about 6 years ago

It should be posted in the forums for more extensive testing first.

#20 Updated by kostamarino about 6 years ago

jake@merdich.com it is for the wii us version that didn't work correct? Please post it in the appropriate forum thread for people to test.

#21 Updated by jake about 6 years ago

Yup- NTSC-U and version 2 (though r5143 reports it as rev0). I'll post it in the forums in a sec.

#23 Updated by Lioncash about 6 years ago

Is this also missing for the JP version of TP as well? If so, then I suppose that's another outlier. Some people are also having issues with regard to that (I don't keep track of this stuff, so if this is already known, then disregard this).

#24 Updated by JMC4789 about 6 years ago

Umm, I misclicked when reading through this and deleted someone's comment. Sorry in advance for whoever that was.

#25 Updated by zhaoyiyuzky about 6 years ago

http://pastie.org/9634679#

I don't know who or when create this. It seems work for the JP version of TP. Please verify the code.

#26 Updated by kostamarino about 6 years ago

I asked people in the forum to test since i don't have the game. If it works as it should then only the japanese gc version will be missing a hyrule field speedhack.
https://forums.dolphin-emu.org/Thread-wii-the-legend-of-zelda-twilight-princess?pid=357688#pid357688

#27 Updated by zhaoyiyuzky about 6 years ago

Meanwhile, I've passed the Goron's Mine. There isn't any glitch so far. And on the hyrule field, I've got pretty stable fps. Does that mean The Code can be put into dolphin officially?

#28 Updated by kostamarino about 6 years ago

zhaoyiyuzky you are the only japanese tester it seems, while i would like some more opinions i have no problem to include it with my next gameini pr. Just wait until it is made and pushed to master, thank you for the info.

#29 Updated by AndyJamesAlban about 6 years ago

I also have said NTSC version and whenever I apply the hyrule field hack, I get the invalid write to errors. How do I add a patch myself for my revision? I don't know how to do so.

#30 Updated by kostamarino about 6 years ago

AndyJamesAlban use the latest dev and enable the alternative speed hack.

#31 Updated by vincentdesrd about 6 years ago

I started getting that same error using Xenoblade Chronicles SX4E01. I'm using all standards options, nothing special.

#32 Updated by skidau about 6 years ago

Are there any missing versions in the latest build?

#33 Updated by kostamarino about 6 years ago

skidau Yes, the japanese gc version.

#34 Updated by kostamarino about 6 years ago

But to be frank with no longer having the need for efb to ram this hack matters even less than it did before.

#35 Updated by hong620 almost 6 years ago

@kostamar

how can i found the right memori address on GZ2J01(NTSC-J GC)?

i'm refer this post
https://code.google.com/p/dolphin-emu/issues/detail?id=2499#c50
https://forums.dolphin-emu.org/Thread-gc-the-legend-of-zelda-twilight-princess--25939?pid=312584#pid312584
http://anago.2ch.net/test/read.cgi/software/1401256876/720

but i'm poor at math & english, so can't understand that address regularity.

i'm guessing First 6 digit for Japan GC seems 802ED5 but i'm not sure..

and Also RZDK01(NTSC-KR Wii) version also not implanted 'Hyrule Field Speed Hack' yet.

so exactly, there's Two Versions of LOZ:TP gamesettings missing Speed Hack.
GZ2J01.ini(GC Japanese)
RZDK01.ini(Wii Korean)

#36 Updated by kostamarino almost 6 years ago

I honestly don't know how to help you, others have found all those codes already in dolphin i deal with settings mostly and push codes to master provided by others.

#37 Updated by JMC4789 over 5 years ago

  • Status changed from Accepted to Fixed

I think all the major versions of Twilight Princess have a speedhack now. I know the korean version is still out there, but the chances of a developer having the game to look into it are much lower.

Closing this issue as of Dolphin 4.0-7318 -> https://dolphin-emu.org/download/dev/cd1071c3a1ff4d0d8c55f9bb6be2056f601e90ad/

#38 Updated by JosJuice over 5 years ago

  • Status changed from Fixed to Accepted
  • Issue type changed from Bug to Feature request
  • Relates to performance set to Yes
  • Priority set to Low

The issue isn't fixed if the speedhack isn't available for every single version. Let's put Priority-Low on it, though.

#39 Updated by JosJuice over 2 years ago

  • Subject changed from ZTP Speed Hack is missing support for certain versions of ZTP to ZTP Speed Hack is missing support for the Korean version of ZTP

Also available in: Atom PDF