Project

General

Profile

Emulator Issues #7898

Starfox Adventures causes GPU Desync (FIFO Overflow)

Added by AndreRyan908 about 5 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?
Star Fox Adventures

Game ID?
GSAP01
(PAL)

What's the problem? Describe what went wrong in few words.
FIFO Overflow, "CPU too fast" warning leading to a lockup.

What did you expect to happen instead?
That the emulator should not desync itself.

What steps will reproduce the problem?
Play the game for a couple of hours, problem may or may not be exacerbated by frame drops (below 100% speed). Occasional "FIFO Overflows" about 30 minutes apart which can be ignored until it finally breaks.

Full crash occurred at "Force Point Temple", a FIFO overflow / "CPU too fast" warning followed by multiple "GFX FIFO: Unknown Opcode" + "Illegal command" windows. The emulator didn't crash, but the screen went black with 0 FPS / 60 VPS; music continued to play but controls don't respond.

Which versions of Dolphin did you test on?
Dolphin 4.0-4368 (Windows/x64)

Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?
I have 4.0-3543 which generates FIFO Overflows every few seconds on the title screen.

What are your PC specifications? (including, but not limited to: Operating
System, CPU and GPU)
Intel Core i7-920 2.66GHz
Radeon HD 5850
Windows 7 x64

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)
Selected 60 FPS / PAL60 on title screen.
Using DSP HLE for better performance. [XAudio2 Backend]
OpenGL Graphics Backend. ["Dolphin 4.0-4368 | JIT64 DC | OpenGL | HLE"]
Using EFB to Texture, Per Pixel Lighting, 16x Anisotropic, Fast Depth disabled.

The first pair of illegal operation windows: http://i.imgur.com/q1ox9DC.png
A save state after the lockup: http://www.filedropper.com/gsap01


Related issues

Is duplicate of Emulator - Emulator Issues #7143: DualCore timing issuesNew

History

#1 Updated by JMC4789 about 5 years ago

  • Status changed from New to Invalid

This has already been fixed :)

#2 Updated by AndreRyan908 about 5 years ago

No it isn't. I'm using a Master build from yesterday (27 hours ago), it's broken.

#3 Updated by JMC4789 about 5 years ago

  • Status changed from Invalid to Questionable

Err, again? Okay, I'll look into it, thanks.

#4 Updated by JMC4789 about 5 years ago

  • Status changed from Questionable to New

Likely a PAL only bug if it's legitimate, unlike the one that was affecting all regions. I can't test it if it's PAL only, don't have the PAL version.

#5 Updated by skidau about 5 years ago

Does the error still occur with DSP LLE? What if you use Single Core?

#6 Updated by AndreRyan908 about 5 years ago

That's problematic to test. I don't have a deterministic set of reproduction steps.

I can set to single core and LLE and see if it crashes again after a few hours or not, but even if it doesn't that won't necessarily prove anything if the issue is non-deterministic.

I do not know any way to narrow this down. I'm aware of the previous FIFO patch/PR which is why I started using this build since the game didn't work at all in earlier revisions. I'd guess that the patch was incomplete, it seems to have only fixed the obvious overflow problems like on the title screen but did not resolve the underlying problem, whatever that is.

#7 Updated by skidau about 5 years ago

Andre, let us know if PR1624 helps. Please test it in Dual Core and DSPHLE mode.

https://github.com/dolphin-emu/dolphin/pull/1624

You can download a build of it here:
http://dl.dolphin-emu.org/prs/pr-1624-dolphin-latest-x64.7z

#8 Updated by darkrocket about 5 years ago

I completed the game a few days ago with https://dl.dolphin-emu.org/prs/pr-1536-dolphin-latest-x64.7z and the bug didn't showed up.

#9 Updated by JMC4789 about 5 years ago

PAL vs NTSC, I'm thinking.

#10 Updated by darkrocket about 5 years ago

I forgot to say that I used the PAL version.

#11 Updated by JMC4789 about 5 years ago

Oh. That makes things much more confusing.

#12 Updated by rigation about 5 years ago

I have the NTSC version: tried it with 4.0-4418 and pr1624 and after a while got into the fifo overflow problem (even with LLE enabled)...for me in this game (at the moment) the only way to avoid the problem seems to be to set Single Core mode (in this way the subtitles desync problem is also fixed)

#13 Updated by JMC4789 about 5 years ago

Do you have idleskipping off?

#14 Updated by rigation about 5 years ago

No, in every test it was always enabled

#15 Updated by rigation about 5 years ago

Made a quick test without idle skip: desynced subtitles are still there, but I didn't encounter the fifo overflow...so tomorrow I will test this a little more

#16 Updated by rigation about 5 years ago

With idle skipping disabled I also have the fifo overflow...I confirm that for now the only way to avoid it in this particular game is to use Single Core (by the way this game doesn't seem to suffer it too much: the speed loss on my system is generally around 15%)

#17 Updated by JMC4789 about 5 years ago

There are certain games that are dualcore sensitive and there's little that can be done in those cases, unfortunately, without a huge amount of work. Hopefully there is some kind of minor flaw causing this, but there's also a chance that it's a core issue.

#18 Updated by JMC4789 about 5 years ago

  • Status changed from New to Duplicate

Going to add this to the general "games that hate dualcore" list. The big issue of it happening every 2 minutes is fixed, and I believe some people said this has happened before.

Also available in: Atom PDF