Project

General

Profile

Emulator Issues #7955

Sound unsynced with OpenAL.

Added by mathieudel almost 6 years ago. Updated over 1 year ago.

Status:
Accepted
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?
Mario Kart Wii

Game ID?
RMCP01

What's the problem? Describe what went wrong in few words.
Using OpenAL sound back-end, no sound is played in main menu, and sound is completely out of sync while in game (starting with fast-forward playback of what did not play in the main menu)

What did you expect to happen instead?
The sound to be in sync with the game.

What steps will reproduce the problem?
[Don't assume we have ever played the game and know any level names. Be as
specific as possible.]
1. Select the OpenAL backend
2. Start the game
3. Listen to the silence
4. Start a new game
5. Listen to the garbage

Dolphin 3.5 and 3.5-367 are old versions of Dolphin that have
known issues and bugs, so don't report issues about them and test the
latest Dolphin version first.
Which versions of Dolphin did you test on?
4.0-4701
Tried down to official 4.0. Sound play seems to start earlier, but still not as expected.

Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?
Dolphin 3.5 works :) !

What are your PC specifications? (including, but not limited to: Operating
System, CPU and GPU)
21" iMac from 2011 :
. 3,06 GHz Intel Core i3
. 8 Go 1333 MHz DDR3
. ATI Radeon HD 4670 256 Mo
. OS X 10.10.1

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)
Nop


Related issues

Has duplicate Emulator - Emulator Issues #8348: US GameCube Service Disc-AudioDuplicate

History

#1 Updated by JMC4789 almost 6 years ago

Have you tried using other audio backends? I've seen this happen with the time-stretching in branches and OpenAL in Dolphin.

#2 Updated by degasus almost 6 years ago

timestreting always have a latency, so don't expect the openal backend to be a sync as the others.

#3 Updated by mathieudel almost 6 years ago

Here I'm talking about no sound at all during all game menu interactions... That's 30 / 40s latency... Considering the game was running at something like 50 or 55FPS, even time stretching could not explain that.

I tried again just to see if that could be an error of mine and it appears the sound starts sooner now, but still several seconds before anything could be heard.

#4 Updated by JMC4789 almost 6 years ago

It takes a long time to catch up; I've ran into this bug too.

#5 Updated by degasus almost 6 years ago

oh, the known latency should be about 200ms ...

#6 Updated by JMC4789 almost 6 years ago

The audio falls behind by 15 - 20 seconds sometimes.

#7 Updated by MofoMan2000 over 5 years ago

I can confirm this issue, only in the OpenAL backend. It happens with all games, though some worse than others (particularly those with cinematics just after boot, such as True Crime: Streets of LA). It seems very system dependent though, because the delay and garbage only lasts a couple seconds for me in MKDD.

#8 Updated by phire over 5 years ago

  • Status changed from New to Accepted

I've seen this happen in other games.

Shrek: Extra Large was the game I notice this happen to last night. It only happens if you have Dual Core enabled and in Shrek it only happens if real or virtual xfb is enabled.

If xfb is disabled, then there is no massive delay, but the audio sounds really stuttery despite running at 60vps (0 fps, it renders the intro videos straight to xfb). I think the time stretching is being fed the wrong timing information.

#10 Updated by flacs over 5 years ago

issue 8348 has been merged into this issue.

#11 Updated by Stevoisiak about 5 years ago

Can confirm this happening to me with the Wii Menu

#12 Updated by phire about 5 years ago

  • Status changed from Accepted to Fix pending
  • Assignee set to phire

Fixed in PR #3053

#13 Updated by theincrediblemastere over 4 years ago

phire

Should this be reverted to "Accepted" now that your PR is Closed?

#14 Updated by phire over 4 years ago

  • Status changed from Fix pending to Accepted
  • Assignee deleted (phire)

#15 Updated by Billiard26 over 1 year ago

Is this issue still present?

Also available in: Atom PDF