Project

General

Profile

Emulator Issues #7963

The Lens Flare in Wind Waker is glitchy in dualcore (CPUTiming)

Added by JMC4789 about 5 years ago. Updated over 2 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
GFX
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game: The Legend of Zelda: The Wind Waker - GZLE01

Description: If you're playing with EFB2RAM, the lenses flare that the game does can glitchy out. At 1X IR, it seems to be most stable in that you can watch work properly for about 20 - 30 seconds before it acts stupid. Once it's broken, it will constantly flicker between working and broken at random intervals.

EFB2Texture does not seem to suffer from this bug, and handles the lenses flare properly. As far as I can tell it handles it just as the console would; without any of the annoying flickering or glitching out that happens on EFB2RAM.

This is also the source of the "seeing the sun through the floor" issue reports we saw. This bug does not show up immediately and in all areas; it seems to pick and choose when it'll show up.

This was discovered in Zelda-HLE 4.0-4727, and reproduced in Master 4.0-4713.

Steps to reproduce:

  1. Go to Dragon Roost Cavern and jump into the pot that takes you to the end of the level.
  2. In the room it takes you, if you have EFB2RAM on, sometimes you'll be able to see the sunlight through the floor. If not, go through the door to the next room outside.
  3. Turn on EFB2RAM, look at the sun, and then move backwards to hide it behind the wall, and the lenses flare will be broken most of the time. Changing the internal resolution will temporarily fix it. 1X IR will fix it longest.

Screenshots: Now in the ultimate bullsh*t move; this bug doesn't show up in fifologs or screenshots! If you take a screenshot of it, the lenses flare will be correctly culled. BUT, we have another way of telling it's broken! The rest of the area will be dimmed as if the lenses flare is out, thus, we can see it is still wrong.

When I took the EFB2RAM screenshot, the sunlight looked bright as hell.

EFB2RAM - https://dl.dropboxusercontent.com/u/484730/GZLE01-23.png
EFB2TEX - https://dl.dropboxusercontent.com/u/484730/GZLE01-24.png

Savefile: Puts you right inside Dragonroost Cavern; just hop in the pot and follow the above instructions. Use slot 2 - https://dl.dropboxusercontent.com/u/484730/01-GZLE-DragonRoostCavernSlot2.gci

Computer Specs: Core i5 3570K, GTX 760, Radeon R9 285, Windows 7 x64


Related issues

Has duplicate Emulator - Emulator Issues #7033: The Legend of Zelda: the Wind Waker - sun in the Dragon Roost VolcanoDuplicate

Is duplicate of Emulator - Emulator Issues #7143: DualCore timing issuesNew

History

#1 Updated by JMC4789 about 5 years ago

issue 7033 has been merged into this issue.

#2 Updated by JMC4789 about 5 years ago

Confirmed in 4.0.2 as well. This is an old bug; perhaps ancient. It's just the properties of it made it difficult to reproduce. Now that we have it figured out, it should be trivial.

#3 Updated by MayImilae about 5 years ago

Huh. That was unexpected. I was unable to reproduce this in 4.0-4603 win64 or 4.0-4715 win64 in either OpenGL or D3D.

I was also unable to reproduce it in 4.0 win64 in OpenGL either. However, I DID reproduce it in 4.0 win64 with D3D.

I tried messing with settings and doing different things, but nothing really changed it (excluding things that totally broke everything of course). The only reason for the difference that I can think of is the different graphics drivers. JMC is running Nvidia's 340 drivers (or something around there, I don't know the specifics, JMC can answer that), while I'm using the older (and more stable) 332 drivers.

Oh, and JMC, you forgot to mention that the clouds can hide the sun. That's kind of important for reproducing this (and very annoying).

While I was at it, I confirmed that console does not have the bug. For the hell of it.

Tested on:
Core i5 3570K @ 4.7ghz
Nvidia GeForce 760 (with 332 drivers)
Windows 7 x64

#4 Updated by JMC4789 about 5 years ago

This bug doesn't happen on Single Core on my NVIDIA or my Radeon R9 285 regardless of settings.

At 4x IR, it can happen on EFB2Texture too; meaning my initial guess was wrong.

#5 Updated by MayImilae about 5 years ago

As said on IRC, in 4.0-4715win64 OpenGL I got the sun to flicker through the mountain by going to 4x native and turning on 4x SSAA. As soon as I turn those extreme settings off, it fixes itself.

#6 Updated by pauldacheez about 5 years ago

ffs, don't fail at ye englische

#7 Updated by JMC4789 almost 5 years ago

issue 7033 has been merged into this issue.

#8 Updated by JMC4789 almost 5 years ago

issue 7033 has been merged into this issue.

#9 Updated by JMC4789 almost 5 years ago

A kind of nasty work-around for this is to use the CPU Clock Override Feature and set it to 80%

#10 Updated by phire almost 5 years ago

So, this is caused by the game starting an EFB copy of the depth buffer and waiting for it to finish before starting to read it.

#12 Updated by JMC4789 almost 3 years ago

#13 Updated by JMC4789 over 2 years ago

  • Status changed from New to Duplicate

Also available in: Atom PDF