Project

General

Profile

Emulator Issues #7999

Super Mario Sunshine crashes Dolphin when loading a save (D3D)

Added by autofire372 over 5 years ago.

Status:
Fixed
Priority:
Urgent
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Current
Regression:
Yes
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

[READ THIS: https://forums.dolphin-emu.org/showthread.php?pid=276132 <<<
Your answers are there!]
[Leave the questions as they are and answer them in the next line]
[Remove lines written inside brackets [], but nothing else]

Game Name?
Super Mario Sunshine

Game ID?
GMSE01

What's the problem? Describe what went wrong in few words.
Dolphin crashed ("Dolphin has stopped working") shortly after the iris-in after loading a save. The game behaves normally in OGL.

What did you expect to happen instead?
I expect Dolphin not to crash in this situation.

What steps will reproduce the problem?
[Don't assume we have ever played the game and know any level names. Be as
specific as possible.]
1. Open Dolphin.
2. Set the GFX backend to D3D.
3. Boot Super Mario Sunshine.
4. Load a save file. The emulator will crash shortly thereafter.

Dolphin 3.5 and 3.5-367 are old versions of Dolphin that have
known issues and bugs, so don't report issues about them and test the
latest Dolphin version first.
Which versions of Dolphin did you test on?
4.0-4441 master, 4.0-4577 master, 4.0-4583 master, 4.0-4699 master, 4.0-4841 new-zelda-hle

Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?
4.0-4441 and 4.0-4577 worked without a hitch.

What are your PC specifications? (including, but not limited to: Operating
System, CPU and GPU)
OS: Windows 8.1 x64
CPU: Intel Core i7-4770k @4.4Ghz
GPU: Nvidia GeForce GTX 970

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)
[Upload big files to a hosting service and post links here!]
Looks like 4.0-4583 (d3d_optimization_cache) is the culprit here.

[Do not attach files to this issue. Upload them to another site and
link here. Use imgur.com for images and pastie.org for logs. Monitor the
email address that was used to create this issue.]


Related issues

Has duplicate Emulator - Emulator Issues #7944: Super Mario Sunshine Crashes on In-Game Load (Since 4.0-4583)Duplicate

History

#1 Updated by JMC4789 over 5 years ago

Unable to reproduce.

#2 Updated by JMC4789 over 5 years ago

  • Status changed from New to Questionable

Is this still afflicting you? Have you tried deleting your shader cache or other things?

#3 Updated by autofire372 over 5 years ago

Yep...deleted my shadercache, tried default settings, wasn't using AR codes...still crashed.

#4 Updated by autofire372 over 5 years ago

For sanity's sake, I just checked the MD5. Unfortunately, it matches the one on redump.org, meaning this isn't a bad dump.

#5 Updated by rodolfoosvaldobogado over 5 years ago

I reproduced the issue but is not related to the savestate itself, it craches with a access violation while applying states at d3d state manager when it try to bind a released texture.

#6 Updated by JMC4789 over 5 years ago

  • Status changed from Questionable to Accepted
  • Priority set to Urgent
  • Regression set to Yes

Huh. Accepting then. Thanks!

#7 Updated by autofire372 over 5 years ago

I apologize. I misspoke in the issue report. I wasn't using savestates—the game was crashing when loading an in-game save file from boot.

#8 Updated by skidau over 5 years ago

issue 7944 has been merged into this issue.

#9 Updated by blabbermoutherish over 5 years ago

Hi, I'm the OP of the duplicate issue that was merged here (7944).

The last thing I was told to do was to test 5 builds of Dolphin (linked here by patrickf, https://1fichier.com/?fl7b511d9y) to try and figure out which commit caused this issue, I did that, and none of the 5 builds worked. The behavior was the same as every build 4.0.4583 and after.

Hope this helps!

#10 Updated by Buddybenj over 5 years ago

  • Milestone set to Current

#11 Updated by JosJuice over 5 years ago

According to this forum post, the crashes are gone: https://forums.dolphin-emu.org/Thread-gc-super-mario-sunshine--25937?pid=363469#pid363469

Is anyone here able to reproduce the issue on an up-to-date development version? If not, this can probably be closed.

#12 Updated by shellashock over 5 years ago

Not able to reproduce the crash using D3D with the most recent build at the time of writing (4.0-5811).

#13 Updated by JMC4789 over 5 years ago

  • Status changed from Accepted to Fixed

Fixed at some point. Cool.

Also available in: Atom PDF