Project

General

Profile

Emulator Issues #8017

Annoying Crashes in Metroid Prime! (GameCube)

Added by mkikoen6196 about 5 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

[READ THIS: https://forums.dolphin-emu.org/showthread.php?pid=276132 <<<
Your answers are there!]
[Leave the questions as they are and answer them in the next line]
[Remove lines written inside brackets [], but nothing else]

Game Name?
Metroid Prime (GameCube)

Game ID?
GM8E01

What's the problem? Describe what went wrong in few words.
Metroid Prime has crashed at least 10 times now due to the stupid error message saying "FIFO is overflown by GatherPipe, CPU thread is too fast!" This is really infuriating me because I'm tired of these annoying FIFO issues forcing Dolphin to crash! Every time it happens whenever I'm in the underwater area trying to access the crashed Frigate Orpheon by using my Thermal Visor to scan invisible Power Conduits and then use the Wave Beam to activate the Power Conduits to power up the doors. Every time the EFB to RAM is enabled by default, the frame rate of the game underwater and in big areas slow down dramatically and I'm done with this nonsense because this is happening too frequently.

What did you expect to happen instead?
For the game to function correctly, have a smooth frame rate, and to gimme a damn break with the crashing due to these annoying FIFO issues.

What steps will reproduce the problem?
[Don't assume we have ever played the game and know any level names. Be as
specific as possible.]
1. If you guys have played Metroid Prime before and have progressed far enough, First just go to Tallon Overworld. Go to the Frigate Crash Site room. If you have the proper items including the Ice Beam or have the cheats enabled, open the ice door, and just progress until you get to a room called the Reactor Access.
2. From this point forward, use the Thermal Visor and if EFB to RAM is enabled, you'll start to see the annoyance of the frame rate dropping dramatically - it's most noticeable as hell whenever you rise out of the water itself when EFB to RAM enabled, with EFB to Texture enabled, the slowdown rarely happens.
3. Eventually in certains rooms, the frame rate will start to slow down so badly to the point where the Dolphin Emulator gives the FIFO Error Message and crashes the game. 😑

Dolphin 3.5 and 3.5-367 are old versions of Dolphin that have
known issues and bugs, so don't report issues about them and test the
latest Dolphin version first.
Which versions of Dolphin did you test on?
Dolphin 4.0-4863

Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?

What are your PC specifications? (including, but not limited to: Operating
System, CPU and GPU)
Macintosh OS X Yosemite
Version 10.10.1
iMac (21.5 inch, Mid 2011)
Processor - 2.5 GHz Intel Core i5
Memory - 4 GB 1333 MHz DDR3
Graphics - AMD Radeon HD 6750M 512 MB

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)
[Upload big files to a hosting service and post links here!]
Here's the most recent Crash Log of Dolphin regarding the FIFO crashes. The specific numbers of CPU Threads in all of the Crash Logs that crashed are CPU Thread: 0, 7, 8, 11.

[Do not attach files to this issue. Upload them to another site and
link here. Use imgur.com for images and pastie.org for logs. Monitor the
email address that was used to create this issue.]


Related issues

Is duplicate of Emulator - Emulator Issues #7143: DualCore timing issuesNew

History

#1 Updated by mkikoen6196 about 5 years ago

Developers, please let me know when all of these annoying FIFO overflown errors that's causing the Dolphin Emulator to crash are fixed in the newest development version whatever version number it is.

Thanks.

#2 Updated by mkikoen6196 about 5 years ago

P.S. If I disable Dual Core, then the Metroid Prime game only runs at half the speed at 50% (30 fps) of the total frame rate which is supposed to be a steady 60 fps. So I have to leave it on.

#3 Updated by JMC4789 about 5 years ago

  • Status changed from New to Duplicate

I take every issue seriously when I test them, so, I went through and followed your instructions. Everything was clear enough for me to get to areas, so I decided to see what I could do to reproduce this.

Unfortunately, on my machine (Core i5 3570K, GTX 760, Windows 7 x64), I don't run into any serious (read: Gamebreaking) problems through this area. True to its reputation, Metroid Prime doesn't disappoint in being one of the more difficult games to run. It requires EFB2RAM which is a lot faster on a GameCube than it is on our hardware, so emulating it is very difficult. For most cases we can cheat with EFB2Texture, but, Metroid Prime uses it in ways we can't cheat with EFB2Texture.

While I was playing through to the area you said, I did get some slowdown (the bad kind of slowdown, FPS dropped while VPS remained stable) which is the kind of bug that can cause the exact issue you're having. Luckily, my computer was fast enough to never fall into the crashing that you described, but I've heard enough stories about it. Unfortunately, we don't accept individualized performance issues, and there's really no "fix" for this individual issue. Anything tackling just this would be a hack; instead, we need to change how Dolphin works in some way.

What's going to end up happening is that this issue will be one of many affected during upcoming rewrites. Since crashing issues are more important than performance issues, I'm going to roll this into the Dualcore Instabilities issue, even though there are other candidates for future issues this may better be suited for.

Thank you for your report.

#4 Updated by mkikoen6196 about 5 years ago

@JMC4789 Thanks a lot for your professional help buddy. I really appreciate at it a lot because unlike the other guy (pauldacheez@gmail.com) when I was reporting about the glitched texture issue in Mario Party 4, the guy was extremely rude and was swearing unprofessionally and offended me. So even though this is off-topic, please report him or talk to him for harassing me because I don't want to deal with him ever again since I tried to block him but there's no preferences on code.google.com to block a certain user.

P.S. After you reply back, please lock this thread.

Thanks again for the help.

#5 Updated by pauldacheez about 5 years ago

I'm always unprofessional with my language! This is a free open-source project, we have no shareholders or customers to appease - only users, and we gain little from appeasing every single one. If you take anything I say as offensive or a personal attack, though, I apologize – that's rarely my intent. Quite frankly, in serious arguments, sane logic is usually more important to me than the feelings of whoever I'm arguing with. I've been in enough stupid arguments with stupid people that I sometimes forget the fact that there's a human on the other side of the internet reading my words, scathing or not.

Back on-topic, Metroid Prime behaves weirdly enough on dual-core (in comparison to other games, at least) that the game itself will hang if the framerate gets low enough. For example, on my MacBook Air (where there's a serious issue with OS X's Intel HD 3000 drivers that makes it drop down to software rendering for any integer-based shaders) jumping into any type of water will cause the drivers to switch to software rendering, which in some cases causes no frames to be rendered for long enough that the game assumes the GPU's hanged, and thus the game freezes with the familiar buzzing noise you hear with the Furnace crash: http://www.metroid2002.com/other_crash_furnace.php

So, yeah, in a nutshell, dual-core just doesn't work perfectly for this game. I'd suggest trying deterministic dual-core, but it seems to be entirely broken right now. v_v;

Also available in: Atom PDF