Project

General

Profile

Emulator Issues #8041

FIFO is overflowed by gatherpipe! CPU thread is too fast!

Added by qqqinbox about 5 years ago. Updated over 2 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?
Blowout
Baldurs Gate: Dark Alliance
Goblin Commander
Roadkill
Crash bandicoot: The Wrath of Cortex

Game ID?
GWOE5G
GDEE71
GGCE0A
GOCE5D
GCBE7D

What's the problem? Describe what went wrong in few words.
Error message "FIFO is overflowed by gatherpipe! CPU thread is too fast!" randomly pops up.

What steps will reproduce the problem?
1. Play those games with dual core enabled

Which versions of Dolphin did you test on?
4.0-4803

Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?
Crash bandicoot: The Wrath of Cortex works fine in v4.0.2. Did not test other games with old versions.

PC specifications:
Operating System: windows 7 x64
Processor/CPU: intel core i5 3570k
Video Card/GPU: radeon 7790
Memory/RAM: 8 Gb

More reports from other users here:
https://forums.dolphin-emu.org/Thread-fifo-is-overflown-by-gatherpipe-cpu-thread-is-too-fast-4-0-926


Related issues

Has duplicate Emulator - Emulator Issues #9034: FIFO is overflowed by gatherpipe! CPU thread is too fast!Duplicate

Is duplicate of Emulator - Emulator Issues #7143: DualCore timing issuesNew

History

#1 Updated by JMC4789 about 5 years ago

I don't have issues with Crash Bandicoot the Wrath of Cortex with dualcore.

#2 Updated by skidau about 5 years ago

Have created a PR to help with this error: https://github.com/dolphin-emu/dolphin/pull/1878

The External Frame Buffer setting must be enabled for this PR to work. Either Virtual or Real is fine. The setting can be found in Dolphin's graphics settings, under Hacks.

A Windows test build can be downloaded here: https://dl.dolphin-emu.org/prs/pr-1878-dolphin-latest-x64.7z

#3 Updated by JMC4789 almost 5 years ago

  • Status changed from New to Fixed

No response, assuming fixed.

#4 Updated by LeVvE.1990 over 4 years ago

I'm currently using 5.0-rc-19 and I have this issue playing "Baldurs Gate: Dark Alliance" so the issue is not fixed.

#5 Updated by qqqbbb over 4 years ago

Sorry for not responding earlier. I opened this this issue. I still get those error messages but now there are much fewer of them.

#6 Updated by MayImilae over 4 years ago

  • Status changed from Fixed to Accepted

More than one user has said this is not fixed, but improved. Reopening!

#7 Updated by MayImilae over 4 years ago

#8 Updated by mstreurman about 3 years ago

as of 5.0-1389 the issue still persists

#9 Updated by mstreurman about 3 years ago

forgot to mention that the issus still persists in Baldur's Gate - Dark Alliance

#10 Updated by JMC4789 about 3 years ago

Does the game actually crash or does it popup and then continue as if nothing happened? Also make sure it shows up in single core if possible.

#11 Updated by qqqbbb almost 3 years ago

JMC4789 wrote:

Does the game actually crash or does it popup and then continue as if nothing happened? Also make sure it shows up in single core if possible.

I did some testing with v5.0-2577 and Baldurs Gate Dark Alliance. The error message pops up only if you have dual core option enabled. The error message dialog box has Yes and No button. If you click Yes, the game continues to run and nothing seems to be wrong but... I left the game running in background for a couple of hours and I got a bunch of error messages. First 2 were "FIFO is overflowed by gatherpipe!...".
3rd error message:
"GFX FIFO: Unknown Opcode (0x13 @ 0000000016CE680F, preprocess=false).
This means one of the following:
* The emulated GPU got desynced, disabling dual core can help
* Command stream corrupted by some spurious memory bug
* This really is an unknown opcode (unlikely)
* Some other sort of of bug"
4th error message:
"Illegal command 13
CPBase: 0x007c0a00
CPEnd: 0x007d09e0
CPHiWatermark: 0x0000c000
CPLoWatermark: 0x00008000
CPReadWriteDistance: 0x00010020
CPWritePointer: 0x007c4bc0
CPReadPointer: 0x007c4ba0
CPBreakpoint: 0x00000000
bFF_GPReadEnable: true
bFF_BPEnable: false
bFF_BPInt: false
bFF_Breakpoint: false
bFF_GPLinkEnable: true
bFF_HiWatermarkInt: false
bFF_LoWatermarkInt: true"
After I closed 4th error message the game seemed to be frozen and the screen was black.

#12 Updated by JMC4789 over 2 years ago

  • Status changed from Accepted to Duplicate

Seems like the typical "dualcore is bad at everything" issue.

#13 Updated by JMC4789 over 2 years ago

Also available in: Atom PDF