Project

General

Profile

Emulator Issues #8059

Super Mario Sunshine - Special stage gray cubes

Added by Anonymous about 6 years ago. Updated 2 months ago.

Status:
Fixed
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:
5.0-13081

Description

Game Name?
Super Mario Sunshine

Game ID?
GMSE01

What's the problem? Describe what went wrong in few words.
In special stages with moving platforms, gray cubes, possibly paths, are visible. These are not seen on Gamecube.

What did you expect to happen instead?
Gray cubes are not visible.

What steps will reproduce the problem?
1. Load Super Mario Sunshine.
2. Enter a special stage
3. eg: Bianco Hills - the first stage unlocked - Episode 6
4. Enter the water-spring cave located on the lake's perimeter. This is located behind and to the right of the windmill island.

Dolphin 3.5 and 3.5-367 are old versions of Dolphin that have
known issues and bugs, so don't report issues about them and test the
latest Dolphin version first.
Which versions of Dolphin did you test on?
Dolphin-zfreeze-x64 7dc6484fe79d, also encountered in the past.

Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?
Not to my knowledge.

What are your PC specifications? (including, but not limited to: Operating
System, CPU and GPU)
W7x64 + intel i5-3570k + nvidia gtx 660

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)
https://www.dropbox.com/s/yl1u00h7782mxbt/d3d.png?dl=0
https://www.dropbox.com/s/hsqkeh2rrv1mhy4/ogl.png?dl=0

<JMC47> jimbo1qaz, it only happens on certain gfx cards on certain settings afaik


Related issues

Has duplicate Emulator - Emulator Issues #9088: SMS: debug boxes show up in "Bianco Hills - Secret of the Dirty Lake"Duplicate

History

#1 Updated by rafayo.agx about 6 years ago

As an extra info, I have tried it to reproduce it and the game does not open on old versions of Dolphin. Settings are not important, it always happens.

#2 Updated by JMC4789 about 6 years ago

  • Status changed from New to Accepted

#3 Updated by JMC4789 about 6 years ago

I reproduced it; I don't remember seeing it before, though.

#4 Updated by pauldacheez about 6 years ago

I saw these on my recent playthrough as well. I'm on a Radeon HD 4670 on OS X 10.10.1, and apparently I was using 4.0-4742 at the time.

#5 Updated by Autoran1 almost 6 years ago

4.0 rev5595
no grey cubes for me
http://i.minus.com/ir1hngJJqot3Y.png
please confirm

#6 Updated by Sonicadvance1 almost 6 years ago

Autoran, they don't appear on those ones. They appear only on the flippy ones that were in the original screenshots.
I've also reproduced.

#7 Updated by JMC4789 over 5 years ago

I tried to record a fifolog of this but it kept crashing.

#8 Updated by phire about 5 years ago

  • Has duplicate Emulator Issues #9088: SMS: debug boxes show up in "Bianco Hills - Secret of the Dirty Lake" added

#9 Updated by Lucario about 5 years ago

Fixed by 4.0-8388

#10 Updated by JosJuice about 5 years ago

  • Status changed from Accepted to Fixed

#11 Updated by JosJuice about 5 years ago

  • Status changed from Fixed to Accepted

#12 Updated by FireNX70 over 3 years ago

This should be fixed by PR 4601.

#13 Updated by Luis over 2 years ago

FireNX70 wrote:

This should be fixed by PR 4601.

Is it?

#14 Updated by JosJuice over 2 years ago

No, the version of PR 4601 that actually was merged doesn't fix this issue. To quote a comment on that PR:

I've decided to split this PR into two, one to fix SMS and one to fix cel-damage. The SMS fix will come later, after additional hardware tests, but this PR (cel-damage fix) is good to go now.

https://github.com/dolphin-emu/dolphin/pull/4601#issuecomment-346056784

#15 Updated by leoetlino 2 months ago

  • Fixed in set to 5.0-13081
  • Status changed from Accepted to Fixed

Also available in: Atom PDF