Project

General

Profile

Emulator Issues #8060

GFX FIFO: Unknown Opcode in Geist

Added by mblsha about 5 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?
Geist

Game ID?
GITE01

What's the problem?
I start Geist with dual-core enabled, and is instantly greeted with this messagebox:
"GFX FIFO: Unknown Opcode (0xff @ 0x110c644d, preprocessing=no).
This means one of the following:
* The emulated GPU got desynced, disabling dual core can help
* Command stream corrupted by some spurious memory bug
* This really is an unknown opcode (unlikely)
* Some other sort of bug

Dolphin will now likely crash or hang. Enjoy."

"Illegal command ff
CPBase: 0x01620cc0
CPEnd: 0x016c8ca0
CPHiWatermark: 0x000a4000
CPLoWatermark: 0x00054000
CPReadWriteDistance: 0x00000480
CPWritePointer: 0x01621580
CPReadPointer: 0x01621100
CPBreakpoint: 0x00000000
bFF_GPReadEnable: false
bFF_BPEnable: false
bFF_BPInt: false
bFF_Breakpoint: false
bFF_GPLinkEnable: true
bFF_HiWatermarkInt: true
bFF_LoWatermarkInt: false"

Then "FIFO is overflowed by GatherPipe !" pops up and Dolphin crashes.

What did you expect to happen instead?
If I disable dual-core, it works fine. In Dolphin 4.0-1575 it hanged a couple of times during a full gameplay, but I can't reproduce it now.

What steps will reproduce the problem?
1. Enable dual-core mode
2. Start Geist. Happens every time for me.

Which versions of Dolphin did you test on?
Dolphin 4.0-4905

Does using an older version of Dolphin solve your issue?
It was the same in Dolphin 4.0-1575, older 4.0 version didn't run Geist at all.

What are your PC specifications?
Mac OS X 10.10.1, 3GHz Xeon E5v2, AMD Firepro D700


Related issues

Is duplicate of Emulator - Emulator Issues #7143: DualCore timing issuesNew

History

#1 Updated by JMC4789 about 5 years ago

  • Status changed from New to Duplicate

I'm unable to reproduce. Filing this under Dualcore Timing issues.

Also available in: Atom PDF