Project

General

Profile

Emulator Issues #8095

Overclocking and underclocking setting (CPU clock override) not saved properly after exiting Dolphin (local issue)

Added by rigation over 5 years ago. Updated over 4 years ago.

Status:
Fixed
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Current
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?
Every game

Game ID?

What's the problem? Describe what went wrong in few words.
As already discussed here https://github.com/dolphin-emu/dolphin/pull/1798 with localised versions of Windows (only 8.1?) there's a problem with the overclocking and underclocking setting: when entering the config/advanced, enabling CPU clock override and setting a new value below 100%, if you exit from Dolphin and relaunch it, starting any game will only give you a black screen, because the value doesn't get saved: now in the config/advanced tab the slider always get set at 0%

What did you expect to happen instead?
Having the chosen value correctly saved after exiting Dolphin, in order to avoid black screen at next game launch

What steps will reproduce the problem?
[Don't assume we have ever played the game and know any level names. Be as
specific as possible.]

  1. Launch Dolphin
  2. Go to the config/advanced tab, enable CPU clock override option and set a new value below 100%
  3. Exit from Dolphin and launch it again
  4. Go to the config/advanced tab: the CPU clock override slider shows 0%

Dolphin 3.5 and 3.5-367 are old versions of Dolphin that have
known issues and bugs, so don't report issues about them and test the
latest Dolphin version first.
Which versions of Dolphin did you test on?
4.0-5078

Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?
None

What are your PC specifications? (including, but not limited to: Operating
System, CPU and GPU)
Windows 8.1 (italian version), Intel e8400, Nvidia Gtx650ti

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)
[Upload big files to a hosting service and post links here!]
The problem seems to occurs only with localised version of the OS (Window 8.1 for sure) and occurs only when you exit Dolphin, in the same "session" the value gets perfectly saved (re-entering the config/advanced has the right value shown)

History

#1 Updated by rodolfoosvaldobogado over 5 years ago

valid issue the locale configuration in the code that generated the config file is geenrating a ',' separated float that is invalid to read when using 'C' locale

#2 Updated by JMC4789 over 5 years ago

  • Status changed from New to Accepted

#3 Updated by rigation over 5 years ago

rodolfoo, your commit https://github.com/Tinob/Ishiiruka/commit/bd061de6b49b0b7b10d0fffb6a9da1276d2d1749 fixes this issue, could you do a Pull Request about it?

#4 Updated by rodolfoosvaldobogado over 5 years ago

that commit will break linux build, i just make a temporal fix, because all ishiiruka user uses windows. more changes are neede to make a correct multiplatform solution.

#5 Updated by rigation over 5 years ago

PR 2004 could also fix this problem?

https://github.com/dolphin-emu/dolphin/pull/2004

#6 Updated by rigation over 5 years ago

Rodolfoo, from the little that I can understand with PR 2004 https://github.com/dolphin-emu/dolphin/pull/2004 merged now linux has the same behaviour as Windows...so I was wondering if it is now possible to apply your fix to master or still not?

#7 Updated by Nucleoprotein about 5 years ago

This was ever fixed on Windows ? I get same issue using r6970.

#8 Updated by rigation about 5 years ago

No, never fixed

#9 Updated by Nucleoprotein about 5 years ago

Hym, hexedit dolphin.exe works - search for ".1252" string (without quotes) and replace with "C" (without quotes too). I too lazy to rebuild from source :p

#10 Updated by phire about 5 years ago

  • Milestone set to Current

I think this should be fixed before 5.0

#11 Updated by Pikachu025 about 5 years ago

Can people with this issue try this build and see if it fixes the problem?
http://dl.dolphin-emu.org/prs/pr-2733-dolphin-latest-x64.7z

Thanks.

#12 Updated by Nucleoprotein about 5 years ago

Still saves coma (,) for Polish locale.

#13 Updated by Nucleoprotein about 5 years ago

PS: I'm using Windows 8.1 Polish, set to default locale settings.

#14 Updated by rigation about 5 years ago

No, it doesn't fix it

#16 Updated by PEmu over 4 years ago

I am not able to reproduce this issue using Dolphin 4.0-8631 in Windows 8.1.

#17 Updated by delroth over 4 years ago

  • Status changed from Accepted to Fixed

Thanks for verifying.

#18 Updated by PEmu over 4 years ago

Re-reading this issue I just want to double check that I actually verified this properly. I am using Windows 8.1 set to English language. Is the issue applicable for that or only for select other languages?

#19 Updated by JosJuice over 4 years ago

  • Status changed from Fixed to Questionable

It probably doesn't happen if you're using English, but I don't know for sure.

#20 Updated by delroth over 4 years ago

It definitely wouldn't happen if your OS is configured to use English language. French or German would be good test cases since they use "," as the decimal separator.

#21 Updated by markwest76 over 4 years ago

I have a localised version of Windows 10 and this is fixed

#22 Updated by delroth over 4 years ago

  • Status changed from Questionable to Fixed

I had someone reproduce the issue on 4.0-8273 with an FR locale and confirm it doesn't happen anymore on latest master. Verified fixed.

Also available in: Atom PDF