Project

General

Profile

Emulator Issues #8096

Terrible sound in Harry Potter and the Sorcerer's Stone (both HLE and LLE)

Added by guitaristocrat3 almost 5 years ago. Updated about 2 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Harry Potter and the Sorcerer's Stone

Game ID?

GHLE69

What's the problem? Describe what went wrong in few words.

Audio during gameplay is full of glitches with every tested backend and DSP setting (even tried LLE Interpreter). These glitches can be either a few crackles or pops all the way up to layered sounds playing at extremely high volume. Cutscenes aren't as bad, but as soon as you get to the first stage it's apparent immediately that something's wrong.

What did you expect to happen instead?

Not to blow my speakers.

What steps will reproduce the problem?
1.Start the game up, select new game, choose your wand at the wand store
2.The next room you enter will be full of jumping puzzles and Every Flavored Beans, try grabbing one
3.Listen to the audio die a horrible death from that point onwards

Dolphin 3.5 and 3.5-367 are old versions of Dolphin that have
known issues and bugs, so don't report issues about them and test the
latest Dolphin version first.
Which versions of Dolphin did you test on?

4.0-4478, 4.0-5091

Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?

There are reports on the wiki of the game working from 3.5-1270 to 4.0-1340 however I haven't tried myself.

What are your PC specifications? (including, but not limited to: Operating
System, CPU and GPU)

Linux Ubuntu 14.10 x86_64, Intel Core i3-3220, nVidia GeForce GTX 650

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)

MD5 Checksum result: 047000888da263ff4485a6756671204f (confirmed with redump.org)

wtfharry2.ogg (846 KB) wtfharry2.ogg JMC4789, 01/18/2016 12:33 PM
69-GHLE-whog_harrypotter.gci (72.1 KB) 69-GHLE-whog_harrypotter.gci JMC4789, 05/10/2016 03:41 AM

Related issues

Is duplicate of Emulator - Emulator Issues #10544: Streaming Audio Issues Across Many GameCube TitlesFixed

History

#1 Updated by JMC4789 almost 5 years ago

  • Status changed from New to Accepted

This is very valid. It appears sounds are just too loud; and sometimes it appears that it loads the wrong voice clips for harry? I don't know, but this is valid.

It happened in 4.0 for me and latest master (4.0-5265)

#2 Updated by guitaristocrat3 almost 5 years ago

i found the most repeatable place you can hear the glitch is in the jumping puzzle room described in the report, if you drop off the platforms to the floor a ladder will be lowered to let you back up which is surrounded by every flavored beans. grabbing these beans always makes a horrible loud screeching noise for me.

on another note though it's weird that the wiki had no reports of this bug happening, it's not like it's something you can avoid or ignore, when the sound glitches happen they're VERY noticeable. first time i heard those static screeching noises it scared the shit out of me, i almost fell out of my desk chair.

#3 Updated by JMC4789 almost 4 years ago

I captured this issue in the act. It's fucking amazing. I think just pausing during any sound effect can trigger it.

I'm just putting delroth on this because it sounds relatively interesting. Feel free to remove yourself if you don't care about this.

#4 Updated by JMC4789 over 3 years ago

Here's a save.

It corresponds to this video - https://www.youtube.com/watch?v=Th8DY320MS0

Just follow the steps displayed there; it spawns at the cutscene.

#5 Updated by Fog over 3 years ago

  • Has duplicate Emulator Issues #8425: Constant crackling sound in Harry Potter and the Chamber of Secrets added

#6 Updated by Fog over 3 years ago

#7 Updated by JosJuice over 3 years ago

  • Has duplicate deleted (Emulator Issues #9677: Harry Potter and the chamber of secrets audio crackling.)

#8 Updated by JosJuice over 3 years ago

  • Has duplicate deleted (Emulator Issues #8425: Constant crackling sound in Harry Potter and the Chamber of Secrets)

#9 Updated by JMC4789 about 2 years ago

  • Status changed from Accepted to Duplicate
  • Assignee deleted (delroth)

#10 Updated by JMC4789 about 2 years ago

Also available in: Atom PDF