Project

General

Profile

Emulator Issues #8101

Innacurate Savestates in 007 Agent Under Fire's Vehicle Levels

Added by aleckermit76 over 6 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?
007: Agent Under Fire

Game ID?

GW7E69

What's the problem? Describe what went wrong in few words.

Savestates made in the vehicle levels 2 & 3, and most likely 7 and 10 as well (although I haven't tested them, cause desyncs in TAS playback. If no re-recordings are made during the recorded playthrough of these levels then they playback fine. I have not experienced any desyncs in on-foot levels.

What did you expect to happen instead?
Accurate savestating for the ability to TAS the entire game.

What steps will reproduce the problem?

  1. Start recording input and beat level 1 in order to access level 2.
  2. Make and load savestates throughout the level as if you were TASing it.
  3. Play the recording back. You will most likely desync at the part where your car drives over the grassy park, at the gas station, or somewhere inside of the building at the end of the level. It seems to like to desync in those spots the most.

Which versions of Dolphin did you test on?

4.0-2182, and multiple older versions (4.0 1xxx), as well as the latest version as of yesterday (4.0-5110).

Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?

No.

What are your PC specifications? (including, but not limited to: Operating
System, CPU and GPU)

Windows 8.1
Intel Core i3-3120M
Integrated Intel Graphics

Is there any other relevant information?

I'm using version 1.00 of the game, Dope Roms is a cool site ;).

I've attached a .dtm of a playthrough that plays through level 3, but it desyncs at the gas station in level 2. This will be useful for getting to level 2 if you haven't played the game before (I die once in level 1, sry about that I was in a rush and hadn't made many savestates before that point).

I have submitted this issue before, here: http://code.google.com/p/dolphin-emu/issues/detail?id=7497&q=agent%20under%20fire

I really want to TAS this game!


Related issues

Is duplicate of Emulator - Emulator Issues #7497: 007 Agent Under Fire - Desyncing in Vehicle Levels During TASDuplicate

History

#1 Updated by JosJuice over 6 years ago

  • Status changed from New to Duplicate

#2 Updated by JosJuice over 6 years ago

Don't submit two very similar issue report for the same issue. Also, no piracy, please.

#3 Updated by aleckermit76 over 6 years ago

Understood, it had been a long time since I submitted the original so I wanted to bring new attention to the issue. 1.00 is not easy to find otherwise.

#4 Updated by JMC4789 over 6 years ago

If you mention piracy on our tracker again, I will close all of your issues.

#5 Updated by JMC4789 over 6 years ago

If this issue were open, I'd close it, for instance. It's just a general rule.

Also available in: Atom PDF