Project

General

Profile

Emulator Issues #8194

NASCAR Thunder 2003-Videos don't output graphics

Added by kolano almost 5 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?
NASCAR Thunder 2003

Game ID?
GNCE69

What's the problem? Describe what went wrong in few words.
Videos don't display, only audio is played.

What did you expect to happen instead?
Cinematics to play both video and audio.

What steps will reproduce the problem?
[Don't assume we have ever played the game and know any level names. Be as
specific as possible.]
1. Start the game
2. Observe white screen instead of opening EA logo.

Dolphin 3.5 and 3.5-367 are old versions of Dolphin that have
known issues and bugs, so don't report issues about them and test the
latest Dolphin version first.
Which versions of Dolphin did you test on?
4.0-5295

Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?
Unsure.

What are your PC specifications? (including, but not limited to: Operating
System, CPU and GPU)
Windows 7 x64, Intel Core it-960, nVidia GeForce 580

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)
The issue can be resolved by enabling XFB=Real, though that reduces the resolution. Would be nice if some of these XFB=Real issues could be resolved /w Virtual.


Related issues

Is duplicate of Emulator - Emulator Issues #8195: Creation of a hybrid xfb mode for games that need real xfb only at certain times ingame (videos for example).Fixed

History

#1 Updated by pauldacheez almost 5 years ago

  • Status changed from New to Accepted

Woohoo, another passenger for kosta's RealXFB train.

#2 Updated by JMC4789 almost 5 years ago

CHOO CHOO.

Adding something here: A lot of the older EA games don't use VP6 videos, Pre Madden 2005, sports titles, etc. Surprised to see this one got caught in it.

#3 Updated by kostamarino almost 5 years ago

Damn, i really hope there was a way for them to be fixed with virtual xfb, a lot of games need to be played at low res to be played properly due to that.

#4 Updated by phire almost 5 years ago

Theoretically a "Hybrid XFB" mode could exist. Acts like virtual xfb unless it (somehow) detect something has been written to the xfb. Then it could switch to real xfb mode.

Someone, create a feature request.

#5 Updated by kostamarino almost 5 years ago

Phiren, as far as videos are concerned when the switch between virtual and real is done manually after a game starts they don't work, they only work if the switch is done before the video plays. Can the detection and switch be done before a video starts?

#6 Updated by phire almost 5 years ago

It's a little more complex than that. Every frame it would have to check if anything has been written to xfb (such a check could be implemented through hashing, filling the xfb with zeros, cache flushes or locking)

Then the xfb would be transferred to the video card and either keyed into the virtual xfb or replacing the complete contents of virtual xfb.

#8 Updated by SergeCCross almost 5 years ago

Viewtiful Joe intro video suffers from the same issue as well

#9 Updated by adiffin502 almost 5 years ago

PCSX2 has a very similar thing, "switch to software rendering when an FMV plays." A Hybrid XFB sounds like a pretty good idea.

#10 Updated by kostamarino almost 5 years ago

  • Status changed from Accepted to Fixed

#11 Updated by MayImilae over 4 years ago

  • Status changed from Fixed to Duplicate

The issue clearly states that RealXFB is a workaround! What the creator wanted was hybrid XFB. So, merging into 8195.

Also available in: Atom PDF