Project

General

Profile

Emulator Issues #8199

The sims freezes with xfb enabled

Added by andrewjameshorton91 about 6 years ago. Updated over 5 years ago.

Status:
Accepted
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
Yes
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?
The Sims

Game ID?
GCIE69

What's the problem? Describe what went wrong in few words.
The latest build causes the game to sometimes stutter on the EA games/The Sims intro, also the game fails to get past the loading screen when loading a saved game and when starting a new game the screen goes black.

What did you expect to happen instead?
Runs nice and smooth with no crashing problems

What steps will reproduce the problem?
1. On startup menu select "Get a life"
2. choose new game
3. screen will go to black
4. restart and choose to load a game and the game freezes when it's about run the 3D game content but doesn't get past the loading screen

Dolphin 3.5 and 3.5-367 are old versions of Dolphin that have
known issues and bugs, so don't report issues about them and test the
latest Dolphin version first.
Which versions of Dolphin did you test on?
Problem extends from 4.0-5070 onwards

Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?
4.0-5068

What are your PC specifications? (including, but not limited to: Operating
System, CPU and GPU)
Windows 8.1
AMD FX-6100
AMD Radeon HD 7870 (Tahiti LE) with 14.12 Omega drivers
8gb DDR3

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)
nope

History

#2 Updated by skidau about 6 years ago

Does checking the "Skip EFB access" option and/or the Disable XFB checkbox make it run like before?

#3 Updated by Buddybenj about 6 years ago

  • Regression set to Yes

#4 Updated by andrewjameshorton91 about 6 years ago

Disabling the XFB seems to have fixed it, I managed to narrow it down to the 5070 build, thought the update may have broken the game but it looks like it's okay with XFB disabled.

#5 Updated by skidau about 6 years ago

Thanks for the info, andrew. I take it that "Skip EFB access" didn't fix this problem?

degasus, does the XFB emulation sometimes ignore swap requests?

#6 Updated by degasus about 6 years ago

Can you try if PR 1992 is still affected? https://dl.dolphin-emu.org/prs/pr-1992-dolphin-latest-x64.7z

#7 Updated by andrewjameshorton91 about 6 years ago

enabling Skip EFB Access seems to fix the stuttering during the intros but the loading screen and black screen freeze is still there, on the other hand disabling XFB fixes both of the problems.

PR 1992 doesn't fix it but when you load the game it takes 10 seconds for the Licensed By Nintendo screen to appear when it should appear instantly, also happens at "The Sims" logo after the intro in which it takes a while before the Press Start message appears.

#8 Updated by JMC4789 about 6 years ago

This used to happen in software renderer too; I'm not sure how much of a regression this is as much as a previous issue being uncovered.

#9 Updated by Buddybenj about 6 years ago

  • Milestone set to Current

#10 Updated by degasus about 6 years ago

Still sounds like a syncing issue to me. Is single core also affected?

#11 Updated by JMC4789 about 6 years ago

  • Status changed from New to Accepted
  • Priority changed from Urgent to Normal
  • Milestone deleted (Current)

It's a dualcore issue.

Can be worked around by either disabling XFB or disabling dualcore.

Confirmed by me on 4.0-5901.

#12 Updated by Buddybenj about 6 years ago

  • Priority changed from Normal to Normal

#13 Updated by JMC4789 over 5 years ago

This is no longer happening for me.

Also available in: Atom PDF