Project

General

Profile

Emulator Issues #8239

Dragon Ball Z Budokai Tenkaichi 3 (characters hided and black area in the top of the window)

Added by mempamal14 over 5 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

[READ THIS: https://forums.dolphin-emu.org/showthread.php?pid=276132 <<<
Your answers are there!]
[Leave the questions as they are and answer them in the next line]
[Remove lines written inside brackets [], but nothing else]

Game Name?
Dragon Ball Z Budokai Tenkaichi 3

Game ID?
RDSPAF

What's the problem? Describe what went wrong in few words.
players hided in the fight area, and black zones in the top of the window.

What did you expect to happen instead?
player visible in the fight area and no black zones.

What steps will reproduce the problem?
[Don't assume we have ever played the game and know any level names. Be as
specific as possible.]
1. Play the game in any area
2.
3.

Dolphin 3.5 and 3.5-367 are old versions of Dolphin that have
known issues and bugs, so don't report issues about them and test the
latest Dolphin version first.
Which versions of Dolphin did you test on?
4.0.5515 x64

Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?
3.5 (x86 & x64)

What are your PC specifications? (including, but not limited to: Operating
System, CPU and GPU)
Windows 7 x64
Intel I5 2410M
Nvidia GeForce 630M
8 Go DDR3

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)

https://www.dropbox.com/s/ij3n3hab2qmawsx/DBZ3%20dolphin%20svn%204.0.5515-cfg1.jpg?dl=0
https://www.dropbox.com/s/6895u7ttak4zbnu/dolphin%20svn%204.0.5515-cfg1.jpg?dl=0
https://www.dropbox.com/s/z50lw61ui1rjygw/dolphin%20svn%204.0.5515-cfg2.jpg?dl=0
https://www.dropbox.com/s/548c6qym6qmfeg2/DBZ3%20dolphin%20svn%204.0.5515-cfg2.jpg?dl=0

i tried to change these Hacks options:
- EFB Copies to RAM
- Image Format Change
- Fast depth calculation
but no concluant results.

[Upload big files to a hosting service and post links here!]

[Do not attach files to this issue. Upload them to another site and
link here. Use imgur.com for images and pastie.org for logs. Monitor the
email address that was used to create this issue.]


Related issues

Is duplicate of Emulator - Emulator Issues #8670: Dragon Ball Z Budokai Tenkaichi 3 Battle BugDuplicate

History

#1 Updated by JMC4789 over 5 years ago

Can you bisect this down a bit? Leaving a range of 8000 builds doesn't give us any idea when a regression could have happened.

#2 Updated by mempamal14 over 5 years ago

i see, so i just tried with several dolphin SVN x64.
- 4.0-2250 (ok)
- 4.0-3777 (ok)
- 4.0-4267 (ok)
- 4.0-4381 (ok)
- 4.0-4430 (ok)
- 4.0-4441 (ok)
- 4.0-4446 (problem appears) (D3D: Replaced shader-based depth range remap with viewport (PR #1392 de kayru))
- 4.0-4453 (problem present)
- 4.0-4461 (problem present)
- 4.0-4511 (problem present)
- 4.0-4589 (problem present)
- 4.0.4667 (problem present)
- 4.0-4798 (problem present)

So with dolphin 4.0-4446 the problems appears ;)

#3 Updated by JMC4789 over 5 years ago

Is there a projection hack in the INI for the game?

#4 Updated by kostamarino over 5 years ago

I know it is a d3d issue and it is due to a change made by karyu. https://github.com/dolphin-emu/dolphin/pull/1392

#5 Updated by mempamal14 over 5 years ago

[Video]
ProjectionHack = 0

also tested with 4.0-5515 with OpenGL backend, and it's better but i have to enable EFB Copies to RAM, if not i have an black squarre in the top left corner...

#6 Updated by JMC4789 over 5 years ago

EFB Copies to RAM makes sense for this. Palleted textures have partial support in EFB2Texture now; which breaks some games and makes others work.

#7 Updated by mempamal14 over 5 years ago

i hope one day this D3D issue will be fixed, with 2 PC systems, D3D backend works better than OGL.
Anyway i congratulate all those who helped in the development of this emulator ;)

#8 Updated by JMC4789 over 5 years ago

You can try latest dev on EFB2Texture, should make stuff less shiny.

#10 Updated by delroth over 5 years ago

  • Status changed from New to Accepted

Can we have a 2-3 frames fifolog for this issue?

JMC, care to add that to FifoCI?

#11 Updated by JMC4789 over 5 years ago

I only have Budokai Tenkaichi 2, and I haven't run into this issue yet.

#14 Updated by mempamal14 over 5 years ago

strange problems appears with my last comment in this thread...
see "deleted comments" for obtain FIFO logs.

#16 Updated by JMC4789 over 5 years ago

I can't see deleted comments.

#17 Updated by rukariosake over 5 years ago

So it appears that the deleted comments are only visible for owners.

#18 Updated by Mr.Greywater over 5 years ago

looks like a viewport issue, forcing the min/maxZ to 0..1 and transforming it to the correct range in the vertex shader (as before) will fix it.

#19 Updated by mempamal14 over 5 years ago

sorry for the "deleted comments" but i have push one time the button for delete one comment, and now, all my comments will be automatically hided !?!

#22 Updated by JMC4789 over 5 years ago

Thanks for the information :) It's a huge help to know what affects it and can fix it.

I'll see if I can't at least do the viewport issue for fifoci so we know when we've fixed it too.

#23 Updated by JMC4789 about 5 years ago

  • Status changed from Accepted to Duplicate

We know what's wrong; budokai 3 uses a true inverted depth range. I'm merging this into the issue that has that information. Thank you so much for your testing, work, and information.

Also available in: Atom PDF