Project

General

Profile

Emulator Issues #8241

Spectrobes Origins Flickering Shadows

Added by nwplayer123 about 6 years ago. Updated over 2 years ago.

Status:
Questionable
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?
Spectrobes Origins

Game ID?
RXXE4Q

What's the problem? Describe what went wrong in few words.
The shadows constantly flicker whenever the character moves.

What did you expect to happen instead?
It to work like it does on console

What steps will reproduce the problem?
1. Open the game
2. Start a new file
3. Look at the shadows after you gain control of the character.

Dolphin 3.5 and 3.5-367 are old versions of Dolphin that have
known issues and bugs, so don't report issues about them and test the
latest Dolphin version first.
Which versions of Dolphin did you test on?
5536 and a compiled version of https://github.com/dolphin-emu/dolphin/pull/2021

Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?

What are your PC specifications? (including, but not limited to: Operating
System, CPU and GPU)
Windows 8, Intel(R) Core(TM) i7-3630QM CPU @ 2.40GHz, NVIDIA® GeForce® GT 635M with 2GB DDR3 VRAM

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)
Deleting the ini setting for using RealXFB slightly fixes it but it still flickers.
http://imgur.com/8O90s45,himonYw
Sorry about my capture card image being darker, but the shadows are also darker I've noticed and I'm not sure how much it has to do with the flickering issue.
This is pretty much the only thing I've seen to stop it from getting a "Perfect" in emulation.

History

#2 Updated by kostamarino about 6 years ago

  • Status changed from New to Questionable

The ini has virtual xfb not real enabled and the whole game is flickering without it, not just shadows. Plus i can't replicate it locally.

#3 Updated by nwplayer123 about 6 years ago

Yes, that happens here too with the flickering. This is actually multiple issues, the RealXFB fix in the INI is only one part of this.

#4 Updated by nwplayer123 about 6 years ago

Clarification: whole screen flickering with no XFB on, like every other frame is black. With Virtual XFB the shadows were flickering a lot. It might be that the difference in lighting from capture card to Dolphin is the same and the shadows are actually perfect, someone would have to do more comparisons.

#5 Updated by JMC4789 about 6 years ago

  • Status changed from Questionable to New

Fifolog is unusable for testing :(

#6 Updated by JMC4789 over 2 years ago

The Shadows match what I'm seeing on console at 1x IR. They're super, super, super, super low resolution and that causes the illusion of flickering. At 8x IR you can tell they're definitely not flickering.

#7 Updated by JMC4789 over 2 years ago

  • Status changed from New to Questionable

Also available in: Atom PDF