Project

General

Profile

Emulator Issues #8250

xbox controller force feedback crashes when testing/doesn't work in-game

Added by mtdyess over 5 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

[READ THIS: https://forums.dolphin-emu.org/showthread.php?pid=276132 <<<
Your answers are there!]
[Leave the questions as they are and answer them in the next line]
[Remove lines written inside brackets [], but nothing else]

Game Name?
n/a

Game ID?
n/a

What's the problem? Describe what went wrong in few words.
When setting up rumble in the GC controller setup I assign both motors by selecting the left then pressing | OR for th right, apply, then click 'test'. after that the whole program freezes until i unplug the controller, then it responds. Also if i dont test it after and try to test it in game it still doesn't work.

What did you expect to happen instead?
for rumble to work.

What steps will reproduce the problem?
[Don't assume we have ever played the game and know any level names. Be as
specific as possible.]
1.assign rumble in GCPad setup as mentioned above.
2.Click Test
3. Unplug controller to make program respond

Dolphin 3.5 and 3.5-367 are old versions of Dolphin that have
known issues and bugs, so don't report issues about them and test the
latest Dolphin version first.
Which versions of Dolphin did you test on?
dolphin 4.0

Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?
Haven't tried

What are your PC specifications? (including, but not limited to: Operating
System, CPU and GPU)
windows 7 64bit sp2
amd fx8320
amd hd6850

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)
N/A

History

#2 Updated by mtdyess over 5 years ago

Michel I believe you are confused. my sxbox controller will let me play games with it fine, other than the rumble/force feedback won't work and freezes(when tested in GCpad Config) the entire program (dolphin 4.0) until the controller is unplugged.

#3 Updated by micheln1986 over 5 years ago

I can't replicate this and i do have a 360 controller

I added Motor L and Motor R, tested them and it worked fine.

#4 Updated by JMC4789 over 5 years ago

  • Status changed from New to Questionable

Try using a newer build of Dolphin; can't reproduce here either.

#5 Updated by loganstromberg over 5 years ago

Could it be a driver issue instead of a Dolphin issue? I own a Super Dual Box Pro and when I tried turning on the rumble feature in Animal Crossing I would get intermittent crashes after about 30 mins of play. I always chalked it up to spotty driver support for force feedback in general.

#6 Updated by mtdyess over 5 years ago

i think it is as im having trouble with other games. I read somewhere that
having multiple drivers installed could be the issue, but i haven't tried
that out yet.

#7 Updated by skidau over 5 years ago

  • Status changed from Questionable to Invalid

Cannot reproduce. Likely caused by a driver issue.

Also available in: Atom PDF