Project

General

Profile

Emulator Issues #8276

Unknown Pointer error in Paper Mario TYD

Added by jeremy.cattau about 5 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?
Paper Mario TYD

Game ID?
G8ME01

What's the problem? Describe what went wrong in few words.
At the start of the game after Luigi reads the letter to Mario, the boat comes on to the screen and then sails off. As the screen fades to white, my game crashes every single time with this error:

"Unknown Pointer 0x03384d40 PC 0x80005d3c LR 0x80005d64

What did you expect to happen instead?
I expected it to go to the next part of the game and not crash

What steps will reproduce the problem?
1. Create save file in game
2. Watch Luigi read letter to Mario
3. Watch boat sail off screen and screen fade to white

Which versions of Dolphin did you test on?
4.0-5568 and 4.0-5672

Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?
No

What are your PC specifications? (including, but not limited to: Operating
System, CPU and GPU)
Intel Core i3 M350 @ 2.27GHz
4GB Ram
64bit Windows 7

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)
I've tried disabling dual core, I've tried Direct3d and OpenGL, and I have Skip EFB to RAM on. I have been able to run every game so far other than this one.

MD5: db9a997a617ee03bbc32336d6945ec02


Related issues

Is duplicate of Emulator - Emulator Issues #8270: Disable Vertex Loader JIT when Bounding Box is needed on older GPUsFixed

History

#1 Updated by JMC4789 about 5 years ago

What's your GPU?

#2 Updated by jeremy.cattau about 5 years ago

NVIDIA GeForce 310M

#3 Updated by JMC4789 about 5 years ago

Does that have OpenGL 4?

#4 Updated by jeremy.cattau about 5 years ago

I'm not sure, how would I find out?

#5 Updated by jeremy.cattau about 5 years ago

After some Googling it looks like it doesn't have 4. Looks like 3.3? So am I SOL for this game? I just find it weird I can play all of the other games I've tried like SSB:M, Mario Party 4, Mario Kart DD, Mario Kart Wii, and Super Mario Strikers.

#6 Updated by JMC4789 about 5 years ago

Paper Mario uses Bounding Box Emulation, which is a bit weird right now. Just wait for degasus to comment. We'll probably merge this in with another issue if what I think is true, it won't be invalid or anything.

#7 Updated by jeremy.cattau about 5 years ago

Ok, I will eagerly wait degasus's reply. Would love to get this game running!

#8 Updated by magumagu9 about 5 years ago

  • Status changed from New to Duplicate

Managed to reproduce this by forcing off bSupportsBBox. Apparently, it tries to do an EFB copy to 0x03384d40. Works flawlessly with both bSupportsBBox and vertex loader JIT forced off.

#9 Updated by jeremy.cattau about 5 years ago

Is that something I can change on my end?

#10 Updated by SuperJesus1 about 5 years ago

I've got the same issue, I get the bSupportsBBox is a bool that should be set to false in the game config, but I'm not sure how to go about setting the vertex loader JIT to off. Any further instruction would be appreciated.

#11 Updated by BenAird about 5 years ago

Very same issue here.

#12 Updated by jeremy.cattau about 5 years ago

Take a look at issue 8270

#13 Updated by domlee590 almost 5 years ago

Same issue here, but it occurs when meeting the Golden Fuzzy.

#14 Updated by ZoolSmith over 4 years ago

Same here, on the 4.0-6930, after killing some Fuzzy and passing a door

#15 Updated by artyomdevasti over 4 years ago

I had the same issue. I just switched to Direct3D and got past that part, saved the game, then switched back to OpenGL.

#16 Updated by degasus over 4 years ago

Which GPU / driver version do you have? It's likely because of an outdated driver.

Also available in: Atom PDF