Project

General

Profile

Emulator Issues #8288

Dolphin Hang in Mario Kart wii when using efb to ram

Added by rodolfoosvaldobogado almost 5 years ago.

Status:
Duplicate
Priority:
Normal
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?
Mario Kart Wii

Game ID?
RMCP01

What's the problem? Describe what went wrong in few words.
Dolphin Crash after multiple messages

What did you expect to happen instead?
no crash

What steps will reproduce the problem?

1.Configure dolphin using d3d and efb To ram
2.In gran prix mode after player selection select GCN Peach Beach
3.The emulator hangs after the intro animation.

Dolphin 3.5 and 3.5-367 are old versions of Dolphin that have
known issues and bugs, so don't report issues about them and test the
latest Dolphin version first.
Which versions of Dolphin did you test on?
4.0-5710

Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?

What are your PC specifications? (including, but not limited to: Operating
System, CPU and GPU)

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)
The issue only happends with d3d


Related issues

Is duplicate of Emulator - Emulator Issues #6923: Mario Kart Wii crashes on D3D with EFB2Ram on during lense flare effectFixed

History

#1 Updated by JMC4789 almost 5 years ago

  • Status changed from New to Duplicate

Galop1n fixed this in his mega commit. There's already an issue about this though.

If you have any idea how he fixed it or come up with a fix, please let us know!

#2 Updated by rodolfoosvaldobogado almost 5 years ago

:) i was not aware of this iisuue i will walk galop's code to see if i can find the fix tanks for the tip.

Also available in: Atom PDF