Project

General

Profile

Emulator Issues #8305

Looney Tunes: Back In Action - Random sound effects and loud audio crackling

Added by Stevoisiak about 5 years ago. Updated over 2 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?
Looney Tunes: Back in Action

Game ID?
GLNE69

What's the problem? Describe what went wrong in few words.
After talking to Foghorn Leghorn, a loud screeching sound will play, followed by various random sound effects. I believe this is related to issue 8069. https://code.google.com/p/dolphin-emu/issues/detail?id=8096&q=sound

What did you expect to happen instead?
For loud noises not to play and break my eardrums.

What steps will reproduce the problem?
1. Load a saved game and select the stage Warner Bros. Studios
2. Select challenge #2, Chimp Chase
3. Cross the street and play through the game as normal up until you dig up Daffy Duck
4. Once he is dug up, ignore the wanted poster mission and go left where you will see a hold you can dig under
5. Go past the hole and keep going until you see the chicken Foghorn Leghorn. Talk to him, and let him finish his dialogue.
6. Remove headphones before the glitched audio kills your ears

Dolphin 3.5 and 3.5-367 are old versions of Dolphin that have
known issues and bugs, so don't report issues about them and test the
latest Dolphin version first.
Which versions of Dolphin did you test on?
4.0-5710
4.0-1344
4.0-982

Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?
No

What are your PC specifications? (including, but not limited to: Operating
System, CPU and GPU)
Windows 8, AMD FX(tm)-6300 Six-Core Processor, AMD Radeon R7 200 Series, 8GB Ram, Realtek High Definition Audio (Driver 6.0.1.6657), AMD High Definition Audio Device (Driver 9.0.0.9905)

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)
Warning. Loud audio.
https://www.youtube.com/watch?v=dzQetSh77T4&t=114


Related issues

Is duplicate of Emulator - Emulator Issues #10544: Streaming Audio Issues Across Many GameCube TitlesFixed

History

#1 Updated by phire about 5 years ago

Does this effect both HLE and LLE sound?

#2 Updated by Stevoisiak about 5 years ago

Yes, this happens in both HLE and LLE

#3 Updated by phire about 5 years ago

Could it be a AI issue?

Can you make sure the disk isn't corrupted.

#4 Updated by phire about 5 years ago

Could also pay to check if it works in JITIL or Interpreter (which will probably require dumping the audio to check) to make sure it's not a jit bug.

#5 Updated by Stevoisiak about 5 years ago

MD5 Verified with redump, 4a3f890fa3eca4bc8b6bec4cf20186f2.
The issue still happens in the JITIL Recompiler.

The issue also happens seemingly randomly at other parts of the game, but talking to Foghorn is a consistent way to reproduce the issue.

#6 Updated by Stevoisiak about 5 years ago

Still happens on interpreter.

#7 Updated by JMC4789 over 2 years ago

  • Status changed from New to Duplicate

#8 Updated by JMC4789 over 2 years ago

Also available in: Atom PDF