Project

General

Profile

Emulator Issues #8310

Metroid Prime morphmall in magmoor cavern

Added by graywolf921 over 5 years ago. Updated almost 5 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?
Metroid Prime

Game ID?
GM8P01

What's the problem? Describe what went wrong in few words.
in the magmoor area called Lava Lake, you have to go into morph mall to blow up a wall. however, as you go into morph ball, the following error occurs, before dolphin shuts down.
Failed to create texture at D3DTexture.cpp, line 56: hr=0x80070057

What did you expect to happen instead?
for the game to proceed to behave as it has done before and let me transform to blow up the wall like it has in other locations in the game

What steps will reproduce the problem?
[Don't assume we have ever played the game and know any level names. Be as
specific as possible.]
1. proceed to the game normally.
2. attempt to blow up the destructable wall at Lava Lake.
3.

Dolphin 3.5 and 3.5-367 are old versions of Dolphin that have
known issues and bugs, so don't report issues about them and test the
latest Dolphin version first.
Which versions of Dolphin did you test on?
4.0-5416, 4.0-5738

Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?
older versions of the emulator are known to have many issues with this game well before this point, making this a fery hard test to perform.

What are your PC specifications? this is an intel I7 HP Pavillion running Windows 7 with a Radeon graphics card. for any more details, please tell me how to get them.

History

#1 Updated by JMC4789 over 5 years ago

in the NTSC version, I went through all of magmoor caverns just last night without issues.

#2 Updated by ZephyrSurfer over 5 years ago

Is the same problem on the OpenGL backend?

#3 Updated by graywolf921 over 5 years ago

this is the PAL version, and i can't use the OpenGL on this videocard

#4 Updated by JMC4789 over 5 years ago

You can't use OpenGL at all on that video card??? It sounds like you have a problem on that video card then.

#5 Updated by Bearborg over 5 years ago

I've had this issue too, and I usually use OpenGL. The issue is unreliable; I've had it happen 3 times in a row, then work fine on the 4th. I haven't experienced it in at least a few months, though, so I had assumed it was fixed by some new build.

#6 Updated by JMC4789 over 5 years ago

Try the latest dev builds. Fix in D3D that may help with this.

#7 Updated by MayImilae over 5 years ago

Can you please instructions to reproduce this? A savefile, a picture of the spot, something? There is no way for me to reproduce this because I don't know where to go!

#8 Updated by graywolf921 over 5 years ago

Replicating settings i found off someone on youtube allowed me to bypass in exchange for emulation speed. Restoring the speed at the next save station caused no further issues so far

#9 Updated by JMC4789 over 5 years ago

  • Status changed from New to Questionable

What settings?

#10 Updated by ZephyrSurfer about 5 years ago

Maybe it's per pixel lighting?

@graywolf...@gmail.com What settings did you change. Post a link to the youtube video.

#11 Updated by JMC4789 almost 5 years ago

  • Status changed from Questionable to Invalid

No response.

Also available in: Atom PDF