Project

General

Profile

Emulator Issues #8317

Bloom/HDR smears and artefacts (Spyro: A Hero's Tail)

Added by megamashmothers over 5 years ago. Updated almost 5 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?
Spyro: A Hero's Tail

Game ID?
G5SP7D

What's the problem? Describe what went wrong in few words.
Messed up bloom/HDR post processing. The game makes extensive use of glowing objects, and it achieves this by overlaying a full-screen "glow map" over the rendered scene. The problem is that the glow map contains smears and weird artefacts that do not belong, and sometimes the glow map isn't even aligned correctly with the objects it's supposed to make glow.

What did you expect to happen instead?
The objects should glow correctly, i.e. no smears or misalignments.

What steps will reproduce the problem?
1. Start Spyro: A Hero's Tail and get through the first cutscene.
2. The game has a lot of objects that glow. They're everywhere, the nearest object at the beginning of the game would be located here (where the arrow is on the map):
http://i.imgur.com/ufIkYba.jpg
And looks like this:
http://i.imgur.com/P7IdDMp.jpg
3. Notice the smears of her wings.

Dolphin 3.5 and 3.5-367 are old versions of Dolphin that have
known issues and bugs, so don't report issues about them and test the
latest Dolphin version first.
Which versions of Dolphin did you test on?

dolphin-4.0.2-r1

Does using an older version of Dolphin solve your issue?

No.

What are your PC specifications? (including, but not limited to: Operating
System, CPU and GPU)

Output from Dolphin:
AMD Phenom II X6 1090T Processor
AuthenticAMD, SSE, SSE2, SSE3, 64-bit support
Note: Option "EFBToTextureEnable" is overridden by game ini.
Dolphin OGL Video Backend
Video Info: NVIDIA Corporation, GeForce GTX 580/PCIe/SSE2, 4.5.0 NVIDIA

System: Linux 3.17.7-gentoo x86_64 GNU/Linux

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)

Screen shots of the problem:
http://i.imgur.com/8T89k77.jpg
http://i.imgur.com/P7IdDMp.jpg

Video of the problem. Note all of the weird smears and blobs of glow everywhere:
https://www.youtube.com/watch?v=-XBNMwTfjYY

Fifo dff (200 frames) of the problem:
https://www.mediafire.com/?4ajk3g3ajs3dady

Please note that EFB Copies was enabled when recording this.

I noticed that disabling EFB Copies (while the game was running) caused the glow map to stop being updated, that is, whatever was on it right before disabling the option would always be overlaid onto the screen, no matter where the camera was pointed.


Related issues

Is duplicate of Emulator - Emulator Issues #6899: Spyro: A Hero's Tail has problems with shimmering on EFB2Tex, EFB2RamFixed

History

#1 Updated by JosJuice over 5 years ago

Does it work on the newest development build? (currently 4.0-5762)

#2 Updated by magumagu9 over 5 years ago

  • Status changed from New to Duplicate

#3 Updated by megamashmothers over 5 years ago

I just tested it on the HEAD of the master branch, commit hash a3f6cbfe6b6320439ea1770ccd6704048eb06c69.

The issue is still present. I made a quick video showing what it looks like, and what happens when you disable the option "Store EFB Copies to Texture".
https://www.youtube.com/watch?v=spBwTw5AyuA

If you need me to test anything else, or provide more info, let me know.

#4 Updated by phire almost 5 years ago

BTW, this bug has 'improved' (deproved?) to the point where there is no bloom for EFB2Tex disabled.

This is because the bloom texture is split into 3 horizontal slices (to fit in the bottom 48px of the framebuffer which is usually un-used for NTSC games.) In older versions of dolphin only the top slice was picked up by the EFB2Tex code, with the bottom row of pixels being smeared down the remaining 2/3rds of the screen.

Doesn't appear to be caught by the current partial texture updates code.

EFB2Ram is uneffected and still broken.

Also available in: Atom PDF