Project

General

Profile

Emulator Issues #8340

Peach's Castle Demo - Welcome to GameCube World Sign

Added by kolano over 5 years ago. Updated over 2 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?
NDDEMO

Game ID?
00

What's the problem? Describe what went wrong in few words.
A thin single pixel line appears beneath the "Welcome to GameCube World" in the beginning of the demo.

What did you expect to happen instead?
No odd line to be rendered.

What steps will reproduce the problem?
1. Start the demo
2. Observe the area beneath the sign as it descends.

Dolphin 3.5 and 3.5-367 are old versions of Dolphin that have
known issues and bugs, so don't report issues about them and test the
latest Dolphin version first.
Which versions of Dolphin did you test on?
4.0-5295

Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?
Unknown

What are your PC specifications? (including, but not limited to: Operating
System, CPU and GPU)
Windows 7, Intel Core i7-960, nVidia GeForce 580

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)
Disabling Dual Core mode seems to resolve this.

TransparentLineConsole.jpg (169 KB) TransparentLineConsole.jpg JMC4789, 05/27/2018 10:02 PM
6801

History

#1 Updated by JMC4789 over 5 years ago

  • Status changed from New to Questionable

I can't reproduce it. Could you provide a screenshot or fifolog showing it? Oh wait, no fifolog if it happens in dualcore only.

#3 Updated by kolano over 5 years ago

It looks like the top two pixels of the sign are either misplaced or duplicated beneath the sign.

#4 Updated by kolano over 5 years ago

Also, this shouldn't state that "Disabling Dual Core mode seems to resolve this.", the issue does still occur /wo Dual Core (I think I was mixed up with other issues reported at the same time). It's not seen when using Software Mode though.

#5 Updated by JMC4789 over 5 years ago

Can yo ustill reproduce the bug? Some depth changes my have fixed this.

#6 Updated by kolano over 5 years ago

Can still reproduce in 4.0-6764.

#7 Updated by JMC4789 over 5 years ago

Does this happen on console? I wonder if it's pixel width. I tried dualcore and single core; it's just very hard to see.

Leaving as questionable because I need to see it on console. If no one else checks it I might.

#8 Updated by kolano over 5 years ago

Not sure. Thanks if you can check it via GC/Wii. I understand that it's barely visible, but it's definitely visible over the door and does seem like a rendering error of some sort.

From what I see on Dolphin it seems like the top row of pixels of the image is incorrectly rendered at the bottom, or perhaps just duplicated there.

#9 Updated by kolano over 5 years ago

I'm mainly interested in this as I have a feeling it might be related to some other rendering issues, such as those seen in Blaster Master Overdrive.

https://code.google.com/p/dolphin-emu/issues/detail?id=6833

#10 Updated by kolano over 5 years ago

Here are two YouTube videos that don't seem to show this issue, though perhaps it just that it's not visible in their low resolution.

https://www.youtube.com/watch?v=5Za-JhLQ_co
https://www.youtube.com/watch?v=jE85lOieDnw

#11 Updated by kolano almost 5 years ago

I no longer see this when using 4.0-8340, though I think it would have been resolved elsewhere. I did recently move from a GeForce 580 to a 970, so also perhaps related to that.

#12 Updated by kolano almost 5 years ago

Oops, spoke too soon. It just went from the sign colored line I saw previously to a black one.

#13 Updated by kolano over 2 years ago

OK. Seems this was resolved sometime before 5.0-7796 and can be closed out.

#14 Updated by JMC4789 over 2 years ago

6801

The issue happens on console.

It's hard to see due to interlacing, but I promise it's there. It cannot be booted with normal BIOS.

Also available in: Atom PDF