Project

General

Profile

Emulator Issues #8348

US GameCube Service Disc-Audio

Added by kolano over 5 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?
US GameCube Service Disc

Game ID?
301E01

What's the problem? Describe what went wrong in few words.
Various audio tests, and audio in the demo output improperly with OpenAL backend.

What did you expect to happen instead?
Audio tests to run correctly, demo audio to play properly.

What steps will reproduce the problem?
1. Select Individual Tests
2. Select Audio Tests
3. Select Left Channel
4. Audio will only play well after test has exited, and plays must faster than appropriate.
5. Return to top menu
6. Select Demo
7. Audio start is delayed and sounds odd

Dolphin 3.5 and 3.5-367 are old versions of Dolphin that have
known issues and bugs, so don't report issues about them and test the
latest Dolphin version first.
Which versions of Dolphin did you test on?
4.0-5823

Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?
Unknown

What are your PC specifications? (including, but not limited to: Operating
System, CPU and GPU)
Windows 7, Intel Core i7-960, nVidia GeForce 580

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)


Related issues

Is duplicate of Emulator - Emulator Issues #7955: Sound unsynced with OpenAL.Accepted

History

#1 Updated by JMC4789 over 5 years ago

Doe sit work in the other backends?

#2 Updated by kolano over 5 years ago

It works correctly using the XAudio2 backend, but that's only on Windows. I don't have access to other OS's to test backends that may be present besides OpenAL on Linux/Mac/Android.

#3 Updated by JMC4789 over 5 years ago

This sounds like the Mario Kart Wii problem in OpenAL.

#4 Updated by kolano over 5 years ago

Yes this does seem to be a dup of 7955.

#5 Updated by flacs over 5 years ago

  • Status changed from New to Duplicate

Also available in: Atom PDF