Project

General

Profile

Emulator Issues #8350

GameCube Service Disc-Poorly Rendered Text

Added by kolano over 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?
US GameCube Service Disc

Game ID?
301E01

What's the problem? Describe what went wrong in few words.
Text is rendered with odd black blips.

What did you expect to happen instead?
Text to be rendered without black blips.

What steps will reproduce the problem?
1. Start the GameCube Service Disc
2. Observe problems with text on initial screen

Dolphin 3.5 and 3.5-367 are old versions of Dolphin that have
known issues and bugs, so don't report issues about them and test the
latest Dolphin version first.
Which versions of Dolphin did you test on?
4.0-5823

Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?
Unknown

What are your PC specifications? (including, but not limited to: Operating
System, CPU and GPU)
Windows 7, Intel Core i7-960, nVidia GeForce 580

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)
https://wiki.dolphin-emu.org/index.php?title=File:Service_Disc-Poorly_Rendered_Text.jpg


Related issues

Is duplicate of Emulator - Emulator Issues #8362: Make IPL fonts width-compatibleNew

History

#1 Updated by kolano over 4 years ago

This can be corrected by using font_ansi.bin extracted from a real GameCube bios.

#2 Updated by JMC4789 over 4 years ago

  • Status changed from New to Questionable

We use unofficial font files; I don't think this is fixable.

#3 Updated by kolano over 4 years ago

It should be fixable with a font more closely aligned with the GC BIOS font. Finding such a font that is freely available is the problem.

#4 Updated by Stevoisiak over 4 years ago

Actually, the text looks just fine in 4.0-1308

#5 Updated by pauldacheez over 4 years ago

Stevoisiak, that's 'cause 1308 had the official fonts illegally included. >_>

#6 Updated by JMC4789 about 4 years ago

  • Status changed from Questionable to Invalid

It wasn't official fonts, it was reverse engineered fonts from another emulator. If someone wants to make an issue report for making a more size appropriate unofficial font, feel free.

#7 Updated by kolano about 4 years ago

Unclear that this issue is invalid, it certainly is a problem for Dolphin /wo a BIOS image.

#8 Updated by kolano about 4 years ago

Created a new issue, 8653, for the font revision enhancement.

#9 Updated by JosJuice about 4 years ago

  • Status changed from Invalid to Duplicate

Also available in: Atom PDF