Project

General

Profile

Emulator Issues #8358

GameCube Service Disc-Hardware Status / Optical Disc Drive Test

Added by kolano over 5 years ago. Updated almost 4 years ago.

Status:
Fixed
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Future
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?
US GameCube Service Disc

Game ID?
301E01

What's the problem? Describe what went wrong in few words.
Immediately fails Test 1:dipronto.dol with error from Dolphin: "DVDInterface tried to execute non-existing command".

What did you expect to happen instead?
Test to pass.

What steps will reproduce the problem?
1. Select Individual Tests
2. Select Hardware Tests
3. Select Optical Disc Drive Test
4. Observe "DVDInterface tried to execute non-existing command" error from Dolphin.
5. Observe Test Failed message.

Dolphin 3.5 and 3.5-367 are old versions of Dolphin that have
known issues and bugs, so don't report issues about them and test the
latest Dolphin version first.
Which versions of Dolphin did you test on?
4.0-5823

Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?
Unknown

What are your PC specifications? (including, but not limited to: Operating
System, CPU and GPU)
Windows 7, Intel Core i7-960, nVidia GeForce 580

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)
https://wiki.dolphin-emu.org/index.php?title=Special:Upload&wpDestFile=Service_Disc-Optical_Disc_Drive_Test.jpg

History

#1 Updated by JosJuice over 5 years ago

Can you check if any of these versions changed the behavior compared to the preceding version? The non-existing command error message wasn't added until 4.0-5531. The older versions may or may not have the same problem regardless of the error message.
4.0-5531 https://dolphin-emu.org/download/dev/8cc6e5cff9cff74483c3cc939f1bc7c934570549/
4.0-4222 https://dolphin-emu.org/download/dev/ba1a8d2ef3e5dd602fa9ac054bcc787d7b400b16/
4.0-1592 https://dolphin-emu.org/download/dev/5391b2dd9c6fab009daf506d89045ab878c02081/

#2 Updated by kolano over 5 years ago

/w 4.0-4222 and 4.0-1592 no Dolphin error is produced, but the test still fails.

#3 Updated by kolano over 5 years ago

4.0-5531 is the same as 4.0-5823. "DVDInterface tried to execute non-existing command" error from Dolphin and failed test post that.

#4 Updated by kolano over 5 years ago

Taking a consistency perspective on this, it seems other non-existing command errors provide a bit more detail on the command that's not implemented (i.e. "SI:Unknown command (0x43)" error" for controllers).

#5 Updated by JosJuice over 5 years ago

The behavior you described about the different versions makes sense. I wonder what happens before 4.0-1592, though. It probably still fails like 4.0-1592, but I can't be sure.

The "non-existing command" error is actually a bit confusingly written. It doesn't mean that there is a command but that the command type is not recognized - it means that DVDInterface is supposed to be executing a command right now, but that its command "slot" (for lack of a better word) is empty for some reason. This should only happen if the emulated software starts a new command while one already is executing. No game does this as far as I know, but I do think the service disc does it. It doesn't really make much sense to submit multiple commands like that, and I don't know what Dolphin is supposed to do in this case.

If you're wondering, the standard unknown command error for DVDInterface is "Unknown DVD command %08x - fatal error" as a panic alert and "Unknown command 0x%08x (Buffer 0x%08x, 0x%x)" in the error log, where %08x is the command type.

#6 Updated by Stevoisiak over 5 years ago

  • Status changed from New to Accepted

#7 Updated by JMC4789 over 5 years ago

  • Milestone set to Future

#9 Updated by flacs almost 4 years ago

  • Status changed from Accepted to Fixed

Also available in: Atom PDF