Project

General

Profile

Emulator Issues #8360

Peach's Castle-Cave

Added by kolano over 5 years ago. Updated over 2 years ago.

Status:
Fixed
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?
Peach's Castle

Game ID?
00

What's the problem? Describe what went wrong in few words.
The cave portion of the demo seems to render without global illumination, so it's much darker than it should be.

What steps will reproduce the problem?
[Don't assume we have ever played the game and know any level names. Be as
specific as possible.]
1. Press start to access the pause menu
2. Select "Return -MAIN MENU
3. Select one of the stage select options
4. Select "CAVE"
5. Observe dark rendering

Dolphin 3.5 and 3.5-367 are old versions of Dolphin that have
known issues and bugs, so don't report issues about them and test the
latest Dolphin version first.
Which versions of Dolphin did you test on?
4.0-5923

Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?
Unknown

What are your PC specifications? (including, but not limited to: Operating
System, CPU and GPU)
Windows 7, Intel Core i7-960, nVidia GeForce 580

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)
https://wiki.dolphin-emu.org/index.php?title=File:Peach%27s_Castle-Cave_Lights.jpg
https://wiki.dolphin-emu.org/index.php?title=File:Peach%27s_Castle-Cave_Lights_on_GameCube.jpg
https://www.youtube.com/watch?v=jE85lOieDnw

History

#1 Updated by JMC4789 over 5 years ago

Is it fixed by this Pull Request -> https://github.com/dolphin-emu/dolphin/pull/2021

#2 Updated by JMC4789 over 5 years ago

  • Status changed from New to Fix pending

#3 Updated by JMC4789 over 5 years ago

  • Status changed from Fix pending to Fixed

Fixed by the lighting attenuation PRs being merged.

#4 Updated by kolano over 5 years ago

I don't think this isn't fixed.

I just checked in 4.0-6743 and 4.0-6820 and things still seem pretty much pitch black when the cave is entered /w both every backend (OpenGL, DirectX, and Software). Please refer to the YouTube video 4:10 where it's shown that the cave walls and railings should be clearly visible.

#5 Updated by kolano over 5 years ago

Er I don't think this is fixed. Darn miscourse revisions.

#6 Updated by JMC4789 over 5 years ago

  • Status changed from Fixed to Accepted

Yeah, I misinterpreted the bug, it's still way too dark. Please give me a fifolog to throw on fifoci.

#7 Updated by JMC4789 almost 5 years ago

I think this may be related to gamma or something? I keep looking at the screenshots and I'm just not sure what's going on.

#8 Updated by Sonicadvance1 almost 5 years ago

Fairly certain this is due to some form of implementation failure in our spot lighting.
Needs more research in to it.

#9 Updated by JMC4789 over 2 years ago

This was fixed with the addition of Copy Filter support.

#10 Updated by JMC4789 over 2 years ago

  • Status changed from Accepted to Fixed

Also available in: Atom PDF