Project

General

Profile

Emulator Issues #8405

Paper Mario: The Thousand-Year Door, some graphics aren't displayed properly since Dolphin 4.0 5143

Added by aldelaro5 over 4 years ago.

Status:
Won't fix
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Paper Mario: The Thousand-Year Door

Game ID?

G8ME01

What's the problem? Describe what went wrong in few words.

Basically, some animatuions has graphics that either just gets way too large than they should, or they are getting enlarged and have just one col;or while they shouldn't. An example is when you use the Paper Mode by pressing R, you should see Paper Mario spins while folding itself to its side while you see a big version of him almost not moving, very enlarged with a cyan like color.

What did you expect to happen instead?

To see the porper animations.

What steps will reproduce the problem?

  1. Start the game and load any files that has the Paper Mode upgrade. You can get a .raw file I used here for testing:

https://www.dropbox.com/s/henpdpbndxlyss9/Rogueport%20North%20After%20Shadow%20Queen.raw?dl=0

You just load the save file named TEST after passing the tittle screen.
2. After you gain control of Paper Mario, press the R button, this will trigger Paper Made and you should see the weird graphics.

Dolphin 3.5 and 3.5-367 are old versions of Dolphin that have
known issues and bugs, so don't report issues about them and test the
latest Dolphin version first.
Which versions of Dolphin did you test on?

Several of them in the 5xxx range. I actually didn't got this issue on older versions and I eventually got that by not having this issue on 4.0 4163, but I had it on the latest as I write this (which is 4.0 5930(.

Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?

I felt adventurous, so I tried to find the oldest versions in which I could reproduce this issue. 4.0 5124 didn't had it while the next one, 4.0 5143 had it. What this means is that this issue got carried since 4.0 5143 and is still present today.

What are your PC specifications? (including, but not limited to: Operating
System, CPU and GPU)

Use this screenshot for reference as it provides all these information:
http://i.imgur.com/WPM1nVO.png

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)

I thought the issue was related to the bounding box setting not being applied correctly so, I added the line UseBBox = True at the end of the ini file, but it didn't solved the issue.

History

#1 Updated by JMC4789 over 4 years ago

  • Status changed from New to Questionable

This is a problem with Intel HD Graphics cards drivers.

#2 Updated by degasus over 4 years ago

Yeah, no bbox support any more but on d3d11 or ogl4.3 gpus. I'm sorry

#3 Updated by JMC4789 over 4 years ago

  • Status changed from Questionable to Won't fix

#4 Updated by degasus over 4 years ago

But good luck, this GPU is able to do OpenGL 4.3, and the patches for mesa are already on the queue. So hopefully we'll have BBOX support on mesa again in less than a year :/

#5 Updated by aldelaro5 over 4 years ago

Yeah, I did my research before to know it's wasn;t hardware, but software issue. Still, I got that very recently, they labelled the extension we need as "in progress" so, it's at least progressing....

Also available in: Atom PDF