Project

General

Profile

Emulator Issues #8409

Silent Hill: Shattered Memories graphical corruption

Added by jschulma about 5 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?
Silent Hill: Shattered Memories

Game ID?
R5WEA4

What's the problem? Describe what went wrong in few words.
Lighting issues, visual artifacts (spots of color or distortion that are only there for a split-second) and white borders at the top and left sides of the screen.

What did you expect to happen instead?
No flickering squares of light and no white borders.

What steps will reproduce the problem?
1. Launch the game, create a save file
2. Watch the intro video
3. When the video portion in the psychiatrists office begins, there will be a white border around the left and top sides of the screen, and the lighting will be strange. Interestingly, using Dolphin's screenshot tool shows the game how it was supposed to look (IE with correct lighting and no borders) instead of capturing the error, so I had to use the Snipping Tool to get a screenshot.

Dolphin 3.5 and 3.5-367 are old versions of Dolphin that have
known issues and bugs, so don't report issues about them and test the
latest Dolphin version first.
Which versions of Dolphin did you test on?
4.0-5932

Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?
Not that I know of.

What are your PC specifications? (including, but not limited to: Operating
System, CPU and GPU)
Core i7-4810MQ, GTX880m, 16gb DDR3 RAM, Windows 8.1 64 bit.

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)
Screenshot of the broken lighting (Since the broken borders are just white, they don't show up in a screenshot with white borders...): http://i.imgur.com/uNEZPYi.jpg

Correct lighting (taken by Dolphin's own screenshot tool): http://i.imgur.com/wTZypvz.jpg

History

#1 Updated by jschulma about 5 years ago

Interesting, apparently the white border DID show up in both screenshots.

#2 Updated by jschulma about 5 years ago

Two things to note:
I tested Pr. 2021, it did not help with the issues.
Happens with both OpenGL and DirectX backends, didn't notice any issues with Software Renderer.

#3 Updated by jschulma about 5 years ago

OK, final comment for now, promise:
I was wrong, the screenshot did NOT show the correct lighting. it just happened to catch it at an instant when the lighting worked. >_> This video has the right lighting: https://www.youtube.com/watch?v=CVshlzP1UeU

IR and Per-Pixel lighting don't change the issue.

#4 Updated by Autoran1 about 5 years ago

To fix this for now turn Scaled EFB Copies OFF and use 1IR or 3 IR others won't work

#5 Updated by jschulma about 5 years ago

Sadly that did not resolve the issue.

#6 Updated by JMC4789 almost 5 years ago

I'm not 100% sure what I'm looking for here. Is it the light on his forehead? Can you test in latest master with and without fast-depth?

#7 Updated by redherochildboss almost 5 years ago

The light on his forehead (which is flickering), little pixelated squares that flicker randomly, and a white border around the screen.

Tried latest master with/without fast depth, no change.

#8 Updated by JMC4789 almost 5 years ago

  • Status changed from New to Invalid

Tested on latest master, 1x IR + RealXFB fixes all of the graphical corruption that I can see. Performance is pretty bad though; fast texture cache seems to help a lot speed wise.

As this was for the white line around the screen + forehead corruption, I'm considered the issue closed.

#9 Updated by jschulma almost 5 years ago

So RealXFB fixes it?
I wonder if Hybrid XFB helps...if it does, that could solve a lot of the performance issues you mentioned. I'll have to test that when Hybrid XFB finally arrives.

#10 Updated by jschulma almost 5 years ago

Also, should RealXFB be forced on in the INI?

#11 Updated by redherochildboss almost 5 years ago

I tried it with RealXFB and 1xIR. The issue is not fixed, though it markedly improved...(4.0-6820)

#12 Updated by JMC4789 almost 5 years ago

Can you make a new issue then? The original issue has two different things. The white border is definitely fixed, and I do see SOME dots in the distance with the flashlight at 1x IR. If we make a new issue for that, I think I can definitely accept it. I don't like this issue as it has a lot of misinformation on how the bug looks, and mentions two defects at once.

#13 Updated by redherochildboss almost 5 years ago

I'd be happy to. So it's the dots and the lighting that's off, then?
And what about the RealXFB INI setting?

#14 Updated by JMC4789 almost 5 years ago

The dots in the distance are the same as the lighting bug. The lines on his forehead are likely the same thing (but doesn't happen at 1x IR?)

#15 Updated by redherochildboss almost 5 years ago

Ah, I see what you mean.
It...sorta happens at 1x? Somewhat?
OK, I'll think about the best way to phrase the ticket and open it once I figure it out.

#16 Updated by JMC4789 almost 5 years ago

I personally think an in-game screenshot with the flashlights dots showing up on the ground is a better example. Also, a console screenshot WITHOUT those dots would be nice too.

Also available in: Atom PDF