Project

General

Profile

Emulator Issues #8425

Constant crackling sound in Harry Potter and the Chamber of Secrets

Added by jstreet91 over 4 years ago. Updated about 2 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?
Harry Potter and the Chamber of Secrets

Game ID?
GHSE69

What's the problem? Describe what went wrong in few words.
Noticeable constant crackling sound

What steps will reproduce the problem?
Just playing the game and walking around

Dolphin 3.5 and 3.5-367 are old versions of Dolphin that have
known issues and bugs, so don't report issues about them and test the
latest Dolphin version first.
Which versions of Dolphin did you test on?
4.0-5954

What are your PC specifications? (including, but not limited to: Operating
System, CPU and GPU)
Win 7 x64, Intel Q6600, GTX 560


Related issues

Has duplicate Emulator - Emulator Issues #9677: Harry Potter and the chamber of secrets audio crackling.Duplicate

Is duplicate of Emulator - Emulator Issues #10544: Streaming Audio Issues Across Many GameCube TitlesFixed

History

#1 Updated by JMC4789 over 4 years ago

Is not running full-speed? If the game isn't running full speed, then it makes sense to crackle as it's running out of buffer.

#2 Updated by jstreet91 over 4 years ago

Yes it is running at full speed, try it for yourself :)

#3 Updated by JMC4789 over 4 years ago

  • Status changed from New to Accepted

Reproduced the issue. Happens on both LLE and HLE audio.

#4 Updated by phire over 3 years ago

#5 Updated by phire over 3 years ago

#6 Updated by phire over 3 years ago

#7 Updated by Fog over 3 years ago

  • Is duplicate of Emulator Issues #8096: Terrible sound in Harry Potter and the Sorcerer's Stone (both HLE and LLE) added

#8 Updated by JosJuice over 3 years ago

Fog: Did you intend to set this as a duplicate or not? There is a related issue that's marked Duplicates, but the issue status isn't set to Duplicate.

#9 Updated by JosJuice over 3 years ago

  • Is duplicate of deleted (Emulator Issues #8096: Terrible sound in Harry Potter and the Sorcerer's Stone (both HLE and LLE))

#10 Updated by Kakkakarrotcake over 2 years ago

Cause of bug:

Hi Guys, after looking into this bug for the past few hours, its safe to say the cause of the clipping is when the in game audio files end. When you walk, or when a character finishes its dialog the clipping sound is made.

It seems this problem is within the game files itself rather than anything the emulator could fix unless there is something to fade the end of the files out.

I hope there is a good fix out there as this game is amazing!

#11 Updated by JMC4789 over 2 years ago

Does this clipping happen on console???

#12 Updated by FireNX70 about 2 years ago

It's definitely not the in the game on console, I just tested it just in case but I've been playing it for years. I doubt it's the dump, since it's happening to multiple people, including myself. I dumped it with Cleanrip on a Wii with The Homebrew Channel and it didn't prompt any error messages. The only way they all could be bad dumps is if the error is on the side of the riping program. It's also not the DSP Rom, since I also tested it with the DSP Rom I dumped from my Wii. My only idea is to dump the game again using my Gamecube (with the Viper GC chip and Cobra BIOS) to confirm that the error is not with the dump itself.

#13 Updated by FireNX70 about 2 years ago

Just thought of something better. I know the dump I'm using right now has clipping on Dolphin, so I can burn that dump and run it on my Wii (I cannot find any blank MiniDVDs and I know I had some somewhere so I'll use regular DVDs, thus I need to use my Wii). If the clipping happens on my Wii, then it would be fairly safe to assume it's a problem with the dumps we're using.

#14 Updated by JosJuice about 2 years ago

I don't think that should be necessary. Others have already reproduced the issue, and CleanRip is a pretty reliable way of making a rip, so there's not much reason to suspect that a bad dump would be the reason for the issue.

#15 Updated by JMC4789 about 2 years ago

The sound crackling is a bug in Dolphin, and does not happen on console. It's actually related to the audio issues in the other Harry Potter games, just incarnations of the same flaw.

It's reading past the end of the files in Dolphin.

#16 Updated by FireNX70 about 2 years ago

So then it IS confirmed to be an issue with Dolphin. JMC4789 asking if it happened on console made me think it wasn't confirmed. Is it a matter of waiting or is there something I can test?

#17 Updated by JMC4789 about 2 years ago

We confirmed it's a bug in Dolphin because a hack caused it to stop happening when testing.

#18 Updated by JMC4789 about 2 years ago

  • Status changed from Accepted to Duplicate

#19 Updated by JMC4789 about 2 years ago

Also available in: Atom PDF