Project

General

Profile

Emulator Issues #8435

Skies of Arcadia Legends hangs in opening sequence

Added by keller.duncan almost 5 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?
Skies of Arcadia Legends

Game ID?
GEAE8P

What's the problem? Describe what went wrong in few words.
Game hangs during the opening sequence

What did you expect to happen instead?
Game continues normally

What steps will reproduce the problem?

1.Watch the opening cutscene
2.Play through the first battle
3.Watch partway through the next cutscene
4.Game crashes a minute or so into that cutscene

Dolphin 3.5 and 3.5-367 are old versions of Dolphin that have
known issues and bugs, so don't report issues about them and test the
latest Dolphin version first.
Which versions of Dolphin did you test on?
4.0-5962

Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?
Did not try an older version

What are your PC specifications? (including, but not limited to: Operating
System, CPU and GPU)
Windows 8.1
Intel i5 sandy bridge
AMD Radeon HD 5770

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)
I don't have a log of the crash, I can replay and get one if need be. I had audio set to use xAudio2, and no framerate limit, other than that all configuration was set to default.


Related issues

Is duplicate of Emulator - Emulator Issues #7143: DualCore timing issuesNew

History

#1 Updated by JMC4789 almost 5 years ago

Have you tried using single core? This is a dualcore sensitive game and you have a weak GPU, so it's possible that's the cause of your issue.

#2 Updated by rigation almost 5 years ago

Go into Sky of Arcadia iso game properties and set deterministic dual core to "fake-completion", this fixes the dual-core crashes for this game (as for many others)

#3 Updated by keller.duncan almost 5 years ago

Thanks for the tips, I will try this as soon as I am able.

#4 Updated by keller.duncan almost 5 years ago

Yep, that seems to have solved it. I just assumed it was some kind of windows 8 issue, thanks for the help.

#5 Updated by haddockd1 almost 5 years ago

If this is a known issue, shouldnt the ini be updated to perform this action as the default?

#6 Updated by JMC4789 almost 5 years ago

  • Status changed from New to Duplicate

No; not all computers run into it.

Also available in: Atom PDF