Project

General

Profile

Emulator Issues #8443

Unknown Pointer Crash in Paper Mario: Thousand Year Door (Dualcore Issue)

Added by TheTomatoCat about 5 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Current
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?
Paper Mario: The Thousand Year Door

Game ID?
G8ME01

What's the problem? Describe what went wrong in few words.
Entering the skull cave on KeelHaul Key after completing the puzzle with Flavio's gem causes dolphin to crash with "Unknown Pointer 0x03384d40 PC 0x80005d40 LR 0x80005d40"

What did you expect to happen instead?
No crash, and the next area to load without issue.

What steps will reproduce the problem?
1. Ask Flavio for the red skull gem and place it into the skull statue.
2. Complete the puzzle with blue and red mustache statues.
3. Throw Bobbery into the hole and enter the cave.

Dolphin 3.5 and 3.5-367 are old versions of Dolphin that have
known issues and bugs, so don't report issues about them and test the
latest Dolphin version first.
Which versions of Dolphin did you test on?
4.0-5964 and 4.0-5987

Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?
No

What are your PC specifications? (including, but not limited to: Operating
System, CPU and GPU)
CPU: i7 - 3930k @ 4.1GHz
GPU: nVidia GTX680, all stock (no overclocking etc)
OS: Win 7 Professional SP1 x64

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)
Graphics are D3D, all GameConfig settings are default

History

#1 Updated by JonnyBomm about 5 years ago

Change your graphics to OpenGL when entering. You should be able to switch back to D3d, but make sure to save frequently because it may crash during other room transitions. Cheers!

#2 Updated by JMC4789 about 5 years ago

I've yet to see a crash in this game. Can you make sure you're not using 2GB or more of RAM when it crashes like this?

#3 Updated by AHeinerm about 5 years ago

Similar unknown pointer dialog that I've posted about in https://code.google.com/p/dolphin-emu/issues/detail?id=7966 . I use OpenGL.

#4 Updated by JMC4789 about 5 years ago

  • Status changed from New to Questionable

Do any of these still happen or happen on single core? I played through the entirety of Paper Mario: The Thousand Year Door not too long ago...

#5 Updated by JMC4789 about 5 years ago

  • Status changed from Questionable to Accepted

Does not happen on Single Core. This is a CPU/GPU desync issue. Thanks everyone for the report, will be looking into this more

#6 Updated by bui almost 5 years ago

+1, though I get this crash right after the screen turns white following the title sequence after the Mario/Luigi scene near the start of the game. Both on OpenGL/Direct3D.

#7 Updated by JMC4789 almost 5 years ago

  • Milestone set to Current

This is a dualcore issue, I've reproduced it and more or less sorted out what's going on. We need to use single core or sync GPU during heavy lag. Should we change how bounding box works or just tell people to use syncGPU for bounding box games?

#8 Updated by bui almost 5 years ago

Neither of those options seem to help much on my end.

#9 Updated by degasus almost 5 years ago

I don't see how this is related to bbox at all. All async querys like efb peeks or perf querys share the same issue.

#10 Updated by JMC4789 almost 5 years ago

I can't reproduce the issue when maintaining a stable framerate, so I'm really not sure why it would be failing.

By stable, I mean FPS and VPS being the same.

#11 Updated by JMC4789 almost 5 years ago

Actually, what's your GPU? There are two ways to get this problem, the second one is to have an Intel HD graphics card.

#12 Updated by bui almost 5 years ago

AMD Radeon HD 8650G + 8750M

#13 Updated by JMC4789 almost 5 years ago

The 8570M should be fine. Does the freeze happen on the same frame every single time?

#14 Updated by bui almost 5 years ago

From what I can tell, yes, the same frame.

#15 Updated by bui almost 5 years ago

Is this of any help?

#16 Updated by JMC4789 almost 5 years ago

You're hitting the "My graphics card doesn't support hw bounding box" crash that I usually blame on Intel HD cards. No idea why that Radeon can't do it though, maybe try updating drivers and whatnot?

#17 Updated by bui almost 5 years ago

I completely forgot to check with Direct3D after enabling GPU sync. It works.

#18 Updated by degasus almost 5 years ago

Yeah, this crash happens if BBox isn't working correctly. Are your drivers up to date?
IIRC older AMD drivers were broken, newer ones are fine. Maybe it's just the same issue here.

#19 Updated by bui almost 5 years ago

Yep, you're right. Updating to Catalyst 14.12 fixed the issue in OpenGL. No need for GPU syncing enabled.

#20 Updated by degasus almost 5 years ago

  • Status changed from Accepted to Invalid

#21 Updated by JMC4789 almost 5 years ago

It's likely using your Intel HD. Try following this guide:
https://forums.dolphin-emu.org/Thread-unofficial-laptop-performance-guide

#22 Updated by degasus almost 5 years ago

Or just use the intel HD GPU and update your (intel) drivers :P

#23 Updated by ltsquigs almost 5 years ago

Hey there,

This is the same person who posted before, just had to delete that comment because I realized I posted it on the wrong account!

I should have mentioned that I already configured Dolphin to be running on the Nvidia card, and the crash still occurs.

For completeness I updated my intel drivers, and tested the same problem on the Intel integrated graphics. The crash still occurs on Intel when using Direct3D, but fixes itself when I switch to OpenGL on Intel. (I also tested the GPU Synch/Single Core stuff while on Intel Direct 3D and that didnt seem to fix it). It still crashes while using the GT 650M with either OpenGL or Direct3D.

#24 Updated by JMC4789 almost 5 years ago

I'll blame optimus then. Try updating all drivers and whatnot. I can't reproduce any issue on a GTX 760 here.

#25 Updated by ltsquigs almost 5 years ago

I updated all the nvidia drivers and the Direct X Runtime and still hit the issue.

I was able to get around it by just disabling the bounding box for that segment (I dont even know what effect its trying to produce there, its not a fancy transition point), and so far havent had any issues since then (or before then). So maybe its just some random bug with that specific transition on 6XX series GeForce cards. (The fact that its the same pointer every time would make me think its not just some timing issue).

Anyways I have a save state right before the transition so I can reproduce it at any time if you want me to with more debugging information, otherwise just disabling it on that one transition seemed to work fine.

Also available in: Atom PDF