Project

General

Profile

Emulator Issues #8490

Frame Rate Issues Window Focus-Dependent For One Game I Tested

Added by wildgoosespeeder about 4 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?
Rocket Power Beach Bandits

Game ID?
GBQE78

What's the problem? Describe what went wrong in few words.
About half normal NTSC-U frame rate with D3D as the backend. Similar thing happens under OpenGL. Noticed that if the window goes out of focus (like if you click something on your taskbar), frame rate is restored to normal. Can't play the game out of focus. Restoring focus to the window brings back the halved frame rate.

What did you expect to happen instead?
Full frame rate when the main window is in focus.

What steps will reproduce the problem?
Just let the game run normally and allow the window to be out-of-focus to see a full frame rate and bring it back into focus to see a slower frame rate.

Dolphin 3.5 and 3.5-367 are old versions of Dolphin that have
known issues and bugs, so don't report issues about them and test the
latest Dolphin version first.
Which versions of Dolphin did you test on?
4.0-6027
4.0-6029
4.0-6046

Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?
No.

What are your PC specifications? (including, but not limited to: Operating
System, CPU and GPU)
Windows 8.1 x64
Intel Core i5 3210M @ 2.5Ghz
NVIDIA GeForce 610M

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)
No.

History

#1 Updated by JMC4789 about 4 years ago

  • Status changed from New to Questionable

I can't reproduce this issue. Are you sure you don't have something like vsync on, that gets disabled when you're on another window?

#2 Updated by wildgoosespeeder about 4 years ago

All default settings. Can I see your CPU and GPU specs? Maybe your CPU and GPU are better than mine because the video found on the Wiki page leads me to believe that the person behind that YouTube channel has better components than I.

https://wiki.dolphin-emu.org/index.php?title=GBQE78

#3 Updated by JMC4789 about 4 years ago

  • Status changed from Questionable to Invalid

I'm going to mark this as invalid because it's most likely an issue with your computer being a laptop that goes into low power mode. I still would love to give you support in figuring out what's wrong, I just don't believe it's an issue with the emulator.

Please follow this guide, https://forums.dolphin-emu.org/Thread-unofficial-laptop-performance-guide and post on the forums for further help. Thank you for the well written report.

#4 Updated by wildgoosespeeder about 4 years ago

OK, that power thing didn't help at all. I was able to narrow it down to there being a problem using an wired Xbox 360 controller as input instead of the keyboard.

#5 Updated by JMC4789 about 4 years ago

I don't see how that can be Dolphin's issue though; that sounds like some kind of power management issue on the computer. I use all kinds of different controllers in Dolphin for various games and can't reproduce a strange behavior like this, unfortunately. Still; it's something I will keep my eyes open for in the future. Maybe with more confirmations/hardware configurations tested, a work-around could possibly be developed.

#6 Updated by JMC4789 about 4 years ago

I don't see how that can be Dolphin's issue though; that sounds like some kind of power management issue on the computer. I use all kinds of different controllers in Dolphin for various games and can't reproduce a strange behavior like this, unfortunately. Still; it's something I will keep my eyes open for in the future. Maybe with more confirmations/hardware configurations tested, a work-around could possibly be developed.

#7 Updated by wildgoosespeeder about 4 years ago

What library is being used to allow input for Windows Dolphin? DirectInput? Is it faulty? Are there different versions of the DirectInput library?

#8 Updated by JMC4789 about 4 years ago

yeah, dinput, and I'm not sure unfortunately

#9 Updated by wildgoosespeeder about 4 years ago

OK, maybe it is XInput because DirectInput doesn't allow for the LT and RT to be pushed down at the same time registering as two separate inputs. DirectInput would cause those triggers to cancel each other out if held down at the same time.

Also available in: Atom PDF