Project

General

Profile

Emulator Issues #8503

Another Code: R sometimes freezes on the pictures menu, but with music playing/distorted

Added by i30817 over 5 years ago. Updated over 4 years ago.

Status:
Fix pending
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?
Another Code: R Journey into lost memories

Game ID?

What's the problem? Describe what went wrong in few words.
Duplicated of closed bug with no feedback - probably because few feedback seems possible - https://code.google.com/p/dolphin-emu/issues/detail?id=5758&can=1&q=%22another%20code%22

It's very strange - sometimes i had no bug for quite a while, but now that i tested it purposefully it started right away in the first world object in a 'new game' (the ). I took a single photo of it entered the photo menu and the game slowed to a crawl and still didn't show the image.

What did you expect to happen instead?
no freeze/slowdown

What steps will reproduce the problem?
[Don't assume we have ever played the game and know any level names. Be as
specific as possible.]
1. Start a new Game
2. Take 1 photo of the first world object (the one placard you can 'examine'
3. Enter the photo menu
on the
My settings are the default ones only i use native internal resolution because my computer is bad.

Dolphin 3.5 and 3.5-367 are old versions of Dolphin that have
known issues and bugs, so don't report issues about them and test the
latest Dolphin version first.
Which versions of Dolphin did you test on?
4.0-5932

Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?
Dunno.

What are your PC specifications? (including, but not limited to: Operating
System, CPU and GPU)
Linux 3.16.0-34-generic #47-Ubuntu SMP Fri Apr 10 18:02:58 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
3,9 GiB
Intel® Core™2 Duo CPU T6600 @ 2.20GHz × 2
Gallium 0.4 on AMD RV710

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)
[Upload big files to a hosting service and post links here!]

the log keeps spaming this: when the bug occurs
28:40:457 /home/buildbot/slaves/dolphin/pack-ubu-x64/build/Source/Core/Core/HW/EXI_DeviceIPL.cpp:272 N[OSREPORT]: << RVL_MWM - TMC_JPEG080314 release build: Mar 14 2008 21:54:51 (0x4199_60831) >>
28:40:457 /home/buildbot/slaves/dolphin/pack-ubu-x64/build/Source/Core/Core/HW/EXI_DeviceIPL.cpp:272 N[OSREPORT]: << RVL_MWM - TMC_JPEG080314 release build: Mar 14 2008 21:54:51 (0x4199_60831) >>

History

#1 Updated by JMC4789 over 5 years ago

Looks like it could possibly be trying to write it to memory card? Try using single core or unplugging all memory cards.

#2 Updated by i30817 over 5 years ago

Can you even remove storage? This is a wii game, not a gamecube one.

#3 Updated by i30817 over 5 years ago

I tried to disable dual core in the game options but it didn't help (i loaded a savestate to skip the large intro though, maybe i should restart).

#4 Updated by phire over 5 years ago

Might be fixed with PR 2649.

Test the build here:
https://dl.dolphin-emu.org/prs/pr-2649-dolphin-latest-x64.7z

#5 Updated by i30817 over 5 years ago

I'm in linux. And that is the reason i realized later it was maybe unlikely to fix it, since linux doesn't have a antivirus constantly scanning open files.

But maybe the problem still applies. Will need a linu version build bot or someone else with the same problem on windows to test though ;)

Maybe i can try to build dolphin with the PR.

#6 Updated by i30817 over 5 years ago

Tried building with the PR merged. Did not work (played with hacks disabled by the way).

Same log spam.

#7 Updated by i30817 over 5 years ago

Maybe i should post a save file too so people can test to see if it reproduces.

In this savefile, the second save presents the problem here when you try to open the photo manipulation app option of the ingame 'device' (i forget the name DAS something).
Dump the files on the directory open after right clicking on the game in the dolphin menu and clicking the "Open Wii save folder" option (euro version, not that i think there is a american one).

#8 Updated by i30817 over 5 years ago

I'd appreciate even a false positive post, so i can stop worrying about it.

#9 Updated by JMC4789 over 4 years ago

  • Status changed from New to Accepted

I've finally gotten this game and can confirm that it's broken. Sorry for the delay. Do you know of any settings that work-around the bug? I've tried everything and can't get it to work.

#10 Updated by JMC4789 over 4 years ago

  • Status changed from Accepted to Fix pending

Also available in: Atom PDF