Project

General

Profile

Emulator Issues #8505

Super Paper Mario - No transitions

Added by fr0ge over 4 years ago. Updated almost 4 years ago.

Status:
Won't fix
Priority:
Normal
Assignee:
Category:
GFX
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
Yes
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?
Super Paper Mario

Game ID?
R8PP01

What's the problem? Describe what went wrong in few words.
In Super Paper Mario, the transitions are non-existant. Entering a door, going down a pipe, etc. This also makes the game uncomplettable, because transitions also don't release pixls (partners) that are required for completting the game. I made these videos to show my problem:
https://mega.co.nz/#!ZxhxXAwA!aAXHu2kWN0KZX-4EAuHzxnci2gVyGE1NvAe7lcmExsU

What did you expect to happen instead?
This game has small cutscenes when you do certain actions, such as going through a door. Doors being opened, after which the character goes inside, and it closes after him. Or when you go inside a building, there is a transition effect going across the screen. Or when you go through a pipe the character is being split into small squares.

What steps will reproduce the problem?
The easiest way to check if the emulator has this problem from a clean save file:
1. Sit through the prologue
2. Right before the first red door that leads to Chapter 1 notice what happens when you press up
3. If the doors opened, there is no problems, however, if the screen just faded to black without doors opening, there is a problem
You'll notice more weird things happen as you play through the game, such as pixls disappearing and you're unable to use them

Dolphin 3.5 and 3.5-367 are old versions of Dolphin that have
known issues and bugs, so don't report issues about them and test the
latest Dolphin version first.
Which versions of Dolphin did you test on?
All versions after 4.0-5915 including the latest 4.0-6068 all have this problem

Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?
Dolphin 4.0-5908 and before all work properly

What are your PC specifications? (including, but not limited to: Operating
System, CPU and GPU)
OS: Windows 7 64 bit
CPU: AMD Athlon II 2 X2 240 (2.81 GHz)
RAM: 2GB
GPU: GeForce GT 240

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)
Videos:
https://mega.co.nz/#!ZxhxXAwA!aAXHu2kWN0KZX-4EAuHzxnci2gVyGE1NvAe7lcmExsU

History

#1 Updated by JMC4789 over 4 years ago

  • Status changed from New to Questionable

Have you tried using EFB2RAM? It's possible the hardware bounding box isn't working properly for some reason on your system.

#2 Updated by fr0ge over 4 years ago

"Store EFB Copies to Texture Only" in the Hacks tab is unchecked if that's what you mean

#3 Updated by JMC4789 over 4 years ago

  • Status changed from Questionable to New

I wonder what would cause this; it's working on the Vertex Loader updates for me...

#4 Updated by flacs over 4 years ago

  • Status changed from New to Won't fix
  • Category set to gfx
  • Regression set to Yes
  • Operating system N/A added

This is a known problem.

Long explanation:
The old vertex loaders supported both a hardware implementation and a very hacky software implementation of bounding box. The new vertex loader JIT only supports the hardware version. It requires a GPU feature that your GPU doesn't have. In 4.0-5915, the new vertex loader JIT gained support for older CPUs that don't support SSSE3 (such as your CPU), so now you're not falling back to the old, slower vertex loader implementation anymore, but it also means bounding box now depends on a feature of your GPU.

tl;dr I just want to play Super Paper Mario asap:
- Use 4.0-5124 or 4.0-5908, whatever is faster for you.
OR
- Buy a new GPU from this list http://delphigl.de/glcapsviewer/listreports2.php?listreportsbyextension=GL_ARB_shader_storage_buffer_object and use the newest version of Dolphin.

Marking as WontFix because the only fix I can think of would be an ugly workaround.

#5 Updated by thepouar almost 4 years ago

You do realize that Mesa is just now supporting OpenGL 4.1 right?

Also available in: Atom PDF