Project

General

Profile

Emulator Issues #8519

Slight Video Playback Issue In Hot Wheels: World Race

Added by wildgoosespeeder over 4 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?
Hot Wheels: World Race

Game ID?
GHRE78

What's the problem? Describe what went wrong in few words.
Just a very slight problem as the game runs just fine everywhere else, but the THQ logo video doesn't play correctly in between the blue copyrights screen and the Climax logo screen. A black screen shows and the THQ sound just plays.

What did you expect to happen instead?
The THQ logo animation showing up and playing the sound associated with the video.

What steps will reproduce the problem?
1. Just start running the game without any button input to skip right to the title screen.

Which versions of Dolphin did you test on?
4.0-6096

Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?
No.

What are your PC specifications? (including, but not limited to: Operating
System, CPU and GPU)
Windows 8.1 x64
Intel Core i5 3210M @ 2.5Ghz
NVIDIA GeForce 610M

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)
No.

History

#1 Updated by JMC4789 over 4 years ago

Probably needs RealXFB set.

#2 Updated by wildgoosespeeder over 4 years ago

Tried that. Didn't work.

#3 Updated by JMC4789 over 4 years ago

  • Status changed from New to Accepted

Works in Software renderer; definitely a confirmed issue. Possibly depth related? Added this to fifoci, thank you so much for bringing this to our attention!

#4 Updated by hk.konpie over 4 years ago

Try set texture cache to 'middle' or 'safe'.

#5 Updated by JMC4789 over 4 years ago

  • Status changed from Accepted to Invalid

Really...?

I've never seen a video totally not function because of that; but there's a first time for everything. Thanks konpie.

Kosta: is it worth upping it to medium or safe to fix this issue?

#6 Updated by kostamarino over 4 years ago

Yes the middle setting is fine. This is one of the reasons i wanted the fast setting to be removed and replaced by the middle one, for about a 2% performance hit many subtle issues such as this could be fixed with no need for the database to fix them, and settings would become even simpler with a fast and a slow setting left.

#7 Updated by wildgoosespeeder over 4 years ago

Alright, thanks for the work-around. I see it now as expected. I'll be sure to update the wiki page.

Also available in: Atom PDF