Project

General

Profile

Emulator Issues #8597

Just dance 3 hang ubisoft logo on dolphin trunk 18370 WITHOUT internet conection (IPC_HLE related)

Added by munoz.yanez almost 5 years ago. Updated over 2 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?
Just dance 3 (Europe)

Game ID?
SJDP41

What's the problem? Describe what went wrong in few words.
The game hangs at the very start (during the ubisoft logo) ONLY when the computer has no internet connection, probably IPC_HLE related.

What did you expect to happen instead?
Obviously not to hang, though this is a minor problem, just hope it can help to improve dolphin, and avoid future issues.

What steps will reproduce the problem?

  1. Stop internet connection
  2. Launch the game (SJDP41)
  3. Wait for the crash at the ubisoft logo.

Dolphin 3.5 and 3.5-367 are old versions of Dolphin that have
known issues and bugs, so don't report issues about them and test the
latest Dolphin version first.
Which versions of Dolphin did you test on?
trunk 18370.

Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?
Do not know

What are your PC specifications? (including, but not limited to: Operating
System, CPU and GPU)
Debian 64 bit, xfce.
amd phenom II 550 (not completely sure, I can check if it matters).
And nvidia gtx 750 (this is for sure) with nvidia-driver 340.76-2.
4 GB Ram.

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)
I had a tip when I saw the emulator waiting for a net connection. Find the log warning line below:
43:43:719 ~/src/dolphin/trunk/Source/Core/Core/IPC_HLE/WII_IPC_HLE.cpp:370 W[WII_IPC_HLE]: Trying to open /dev/net/ssl as 9

[Do not attach files to this issue. Upload them to another site and
link here. Use imgur.com for images and pastie.org for logs. Monitor the
email address that was used to create this issue.]

History

#1 Updated by JMC4789 almost 5 years ago

That's strange... Will ping Parlane, not sure if he'll actually look into it or not, though.

#2 Updated by parlane almost 5 years ago

Weird, net is all done in a thread. So it shouldn't be possible to hang when making an SSL connection.

#3 Updated by munoz.yanez almost 5 years ago

Yep, it sounds strange. It seems like another thread is waiting for something related to the net thread.
Also, can it be located in another place (not the net thread) that waits to access the internet, and blocks the game?
I have been testing further, and removing inet connection blocks the game at the logo and also at the menus, but not inside the songs. Does that game have some stats sent trough internet like the scores or so?

#4 Updated by mbc07 almost 5 years ago

Couldn't reproduce here, however I have NTSC-U version (not sure if it'll make difference). Turned WiFi off and unplugged Ethernet cable (just to be sure) and no hangs, even played 3 songs, no problems at all, tested on 4.0-6430...

#5 Updated by munoz.yanez almost 5 years ago

We may close the issue then, as I seem to be the only having this problem. If someone can give me some advice in debugging I could try to find it in the source. This strange bugs use to cause good headache and unexpected problems.
I tested just dance 4 NTSC (SJXE41) having the same issue.

#6 Updated by JMC4789 almost 5 years ago

I have no idea what you could do to find more, unfortunately.

#7 Updated by leoetlino over 2 years ago

  • Status changed from New to Invalid

Can't reproduce the issue either on a PAL version. In fact it doesn't appear to open /dev/net/ssl during the opening sequence at all.

Also available in: Atom PDF