Project

General

Profile

Emulator Issues #8626

Harry Potter Sorcerer's Stone texture glitches

Added by guitaristocrat3 over 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Harry Potter and the Sorcerer's Stone

Game ID?

GHLE69

What's the problem? Describe what went wrong in few words.

Textures in this game are all over the place; random textures will get replaced with other random textures, most commonly seen from my experience when leaving the castle to go to the grounds, coming back inside, and leaving again. I have taken many screenshots which I'll put at the bottom. It also is getting worse the longer I play the game with spots that were normally fine slowly becoming more unstable, like the staircase in the last screenshot.

What did you expect to happen instead?

I expected the game to look normal and not give me nightmares.

What steps will reproduce the problem?
1. Play until you get to Hogwarts and get the ability to leave the castle
2. Walk outside, walk inside, walk outside
3. See texture glitches

Dolphin 3.5 and 3.5-367 are old versions of Dolphin that have
known issues and bugs, so don't report issues about them and test the
latest Dolphin version first.
Which versions of Dolphin did you test on?

4.0-6554, 4.0-6543

Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?

No, from my experience this game has always been buggy but I never made it far enough to see this glitch until recently.

What are your PC specifications? (including, but not limited to: Operating
System, CPU and GPU)

Linux Ubuntu 14.10
Intel Core i3-3220 @ 3.3GHz
NVIDIA GeForce GTX 650

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)

Screenshots:
http://i.gyazo.com/56360428edf9c02adfef8a244204086e.png trees affected by texture glitching
http://i.gyazo.com/b67a319029cc602e52f691e16745202a.png on leaving and coming back the trees were normal but the hills were affected
http://i.gyazo.com/4af4b27990b412c2e17e448545b3476b.png you can walk around on it too
http://i.gyazo.com/7e6185ff86bfa1c5e28ad57d42137fec.png the numbers on the hourglasses are where that texture is coming from, that door in screenshot is the door that leads outside too
http://i.gyazo.com/346c1300eab5e54ae03bda6a231dce5d.png it started happening inside as well (usually the walls are a solid light color)

Every setting is on default

MD5 confirmed with redump: http://redump.org/disc/9084/
047000888da263ff4485a6756671204f

It's probably also relevant that between this and issue 8096 I've become convinced that my copy of this game is haunted or possessed by some unknown demonic force.


Related issues

Is duplicate of Emulator - Emulator Issues #8299: Metroid Prime sometimes overrides textures with EFB Copies (Store EFB Copies to Texture Only)Fixed

History

#1 Updated by JMC4789 over 4 years ago

Have you tried unchecking "Store EFB Copies to Texture" or setting the texture cache slider to safe?

And yeah, that audio bug is some trippy stuff.

#2 Updated by guitaristocrat3 over 4 years ago

No, now that you mention it I should've tried that...

Texture cache accuracy has no effect except making the glitch happen in different places, but EFB to RAM seems to fix it, or at least make it a lot more stable. I went to the usual trouble spots and could easily reproduce it without the setting, but turning it on none of the glitches happened while I was trying it out.

#3 Updated by JMC4789 over 4 years ago

  • Status changed from New to Duplicate

Okay, I'm adding your glitch to another game then.

Also available in: Atom PDF