Project

General

Profile

Emulator Issues #8627

Audio Crackling/Stopping while running Dolphin (All programs)

Added by stanka410 over 5 years ago.

Status:
New
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?Super Smash Bros Melee

Game ID? GALE01

What's the problem? Describe what went wrong in few words.

Audio Crackling. Sometimes audio cuts completley

What did you expect to happen instead?

What steps will reproduce the problem?

  1. Open dolphin (weird things happen here for me. if I have music running, the audio quality of the music drops)
  2. Run the Super Smash Bros Melee

Dolphin 3.5 and 3.5-367 are old versions of Dolphin that have
known issues and bugs, so don't report issues about them and test the
latest Dolphin version first.

Which versions of Dolphin did you test on?
4.0-6554

Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?

I play this game mostly on 4.0-5886 but have test and the most recent version that I do not have this issue is on 4.0-6135

What are your PC specifications? (including, but not limited to: Operating
System, CPU and GPU)

OS: Win7 64 Bit SP1
CPU: Intel Core i7 2600K @ 3.40GHz
RAM: 16.0 GB Dual-Channel DDR3
MOBO: ASRock Z77 Extreme4
GPU: 1279MB GeForce GTX 570 (EVGA)

Is there any other relevant information?

http://i.imgur.com/bu90Z0L.png
Settings used for 6554

[Do not attach files to this issue. Upload them to another site and
link here. Use imgur.com for images and pastie.org for logs. Monitor the
email address that was used to create this issue.]

History

#1 Updated by stanka410 over 5 years ago

What did you expect to happen instead?

The audio not to crackle. It is smooth in other versions.

#2 Updated by stanka410 over 5 years ago

Which versions of Dolphin did you test on?
4.0-6554 and 4.0-6562

#3 Updated by JMC4789 over 5 years ago

I did more research into the issue with this user; their entire audio system has the problem while running Dolphin. The culprit is the background thread to check for the GameCube Controller Adapter.

#4 Updated by tekrox over 5 years ago

I have also had a very similar issue, tested on builds 6697 and 6500

When running Dolphin, after about 2-3 minutes (no emulation required, having Dolphin open is enough) Windows sound cuts out entirely, closing dolphin does not rectify the issue.

Unplugging and replugging in my USB DAC does fix the issue, but if dolphin is still open it will fail again in 2-3 minutes.

OS: Win 8.1 x64
CPU: Intel Core i7 4820K @ 4.3ghz
RAM: 32GB Quad-Channel DDR3
MOBO: Gigabyte X79-UP4
GPU: 8192MB Radeon R9-290X
SOUND: USB Sound Blaster Digital Music Premium HD (No Creative Drivers installed, using Windows stock USB Audio Class drivers.)

Expected Behavior: Audio continues to function

#5 Updated by stanka410 over 5 years ago

Checked on build 6736

Same issues still occurring.

#6 Updated by stanka410 over 5 years ago

Are you overclocked by any chance?

#7 Updated by stanka410 over 5 years ago

I changed from my USB headset (had audio problems) to my speakers that plug into the back of the PC aka the mobo and there were no audio issues.

My headset is a steelseries 9h.

Opened dolphin without mayflash adapter plugged in and still had audio issues.

Something with the USBs and Gamecube controller adapter like JMC said. We know its that because thats when dolphin started having this issue after 4.0-6135

#8 Updated by stanka410 over 5 years ago

Could this be part of the problem? Says adapter is not detected (which is correct) but still gives me options?

http://i.imgur.com/EaHhC8m.jpg

version on left is 4.0-6138

#9 Updated by nico.reid87 over 5 years ago

i played this game on the 3.0 version n i had no issues at all, non whats so ever after i updated microsoft visual c++ redistributable to all the new versions from 2008 - 2013 and i also updated my graphics card driver n netframe work.

but i played it on the 4.0 n newer version n still get that audio crackling, i also get it on def jam fight for ny

#10 Updated by tom8476oo about 5 years ago

#8 same headset , and get similar issue about audio
tested on 7304 build.

#11 Updated by JMC4789 about 5 years ago

Please retest in the latest version of Dolphin now, was a small change to this.

#12 Updated by tekrox about 5 years ago

I just tried Wind Waker running on Build 7325 for over a hour, USB DAC still working A-OK.

Looking good from here!
Big thanks to JMC4789, MaJoRoesch and mathieui for making this happen :)

#13 Updated by Josh_Lusby about 5 years ago

I am using a USB Audio 7.1 adapter, and I am still not getting any sound on the latest version (4.0-7345). Going backwards and testing prior revisions, I am able to get sound working on 4.0-5400. I was going back in 100 increments, and still got no sound as old as 4.0-5600, so I'm not exactly sure when sound stopped working. Hopefully this will be helpful in isolating the problem and a fix though, thanks!

Also available in: Atom PDF