Project

General

Profile

Emulator Issues #8641

Xenoblade Crash

Added by theincrediblemastere about 5 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?
Xenoblade Chronicles

Game ID?
SX4E01

What's the problem? Describe what went wrong in few words.
Random crash. Maybe I did too many things at once?

What did you expect to happen instead?
For it to lag to hell but not crash.

What steps will reproduce the problem?
1. Well, I went to the Judicial District in Agniratha and fought a bunch of enemies
2. After using Fiora's Gun Drones II, the FPS count went to 0 with the music and the VPS still going

Dolphin 3.5 and 3.5-367 are old versions of Dolphin that have
known issues and bugs, so don't report issues about them and test the
latest Dolphin version first.
Which versions of Dolphin did you test on?
4.0-6957

Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?
Haven't checked.

What are your PC specifications? (including, but not limited to: Operating
System, CPU and GPU)
Windows 7 x64
Intel i7 4770
nVidia GeForce GTX 760 (GV-N760OC-2GD REV2.0)
8GB G.Skill Sniper Low-Voltage series @ 1600MHz 9-9-9-24

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)

My save file and a save state I created after it happened: http://www.mediafire.com/download/zjuio9u51v4sjou/Xenoblade_Files.zip

I get the feeling it's just a simple "did too much crap at once" crash. But just so that other people don't lose a few hours like I did...


Related issues

Is duplicate of Emulator - Emulator Issues #7143: DualCore timing issuesNew

History

#1 Updated by JMC4789 about 5 years ago

What likely happened is that the CPU and GPU threads became too far separated and the game crashed. The only thing that can be done about this is to either use the synchronize GPU option or single core.

If you can reproduce the crash with those options, then this is likely a serious issue.

#2 Updated by degasus about 5 years ago

  • Status changed from New to Questionable

"the FPS count went to 0 with the music and the VPS still going"
This is an ingame crash. So through it is captured within the save state, this is by far enough to debug the dolphin issue which did lead to this crash.

Such crashes are often bugs in the games which aren't triggered on the real console.

#3 Updated by theincrediblemastere about 5 years ago

Strange that I didn't get that iconic "crash" noise that we all know and love.

Ah well. Makes sense to me. Maybe I'll see if I can throw it off balance again later.

#4 Updated by JMC4789 about 5 years ago

  • Status changed from Questionable to Duplicate

Okay. Thanks. Please find any dualcore crashes and report them into the issue I'm putting this with!

Also available in: Atom PDF