Project

General

Profile

Emulator Issues #8653

Improper Font Widths

Added by kolano about 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?
Various, but including: Pokémon Colosseum Bonus Disc, Service Disc. Many other titles are likely effected.

Game ID?
Various

What's the problem? Describe what went wrong in few words.
Characters in the fonts distributed with Dolphin are misaligned with the widths of the fonts used on the GameCube/Wii. This causes various text to render improperly.

What did you expect to happen instead?
Fonts to more closely align with the official GameCube/Wii fonts.

What steps will reproduce the problem?
[Don't assume we have ever played the game and know any level names. Be as
specific as possible.]
1. Start the GameCube Service Disc
2. Observe problems with text on initial screen

Dolphin 3.5 and 3.5-367 are old versions of Dolphin that have
known issues and bugs, so don't report issues about them and test the
latest Dolphin version first.
Which versions of Dolphin did you test on?
Any version outside a small set of releases around 4.0-1308, which included the official fonts (or perhaps just a more closely aligned one)

Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?
Yes, in theory 4.0-1308 worked better, but I believe that's because it included a font we are unlicensed to use.

What are your PC specifications? (including, but not limited to: Operating
System, CPU and GPU)
Irrelevant

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)
https://wiki.dolphin-emu.org/index.php?title=File:Service_Disc-Poorly_Rendered_Text.jpg
https://wiki.dolphin-emu.org/index.php?title=File:PCBD_Font_Wrong.png


Related issues

Is duplicate of Emulator - Emulator Issues #8362: Make IPL fonts width-compatibleNew

History

#2 Updated by kolano about 4 years ago

Yes, sorry. We should likely merge 8350 there as well.

#3 Updated by JosJuice about 4 years ago

  • Status changed from New to Duplicate

Also available in: Atom PDF